summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-12-01 20:03:38 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-12-01 20:03:38 +0000
commit75325fffe15c484b5173513bea0bba4657e4aee0 (patch)
treee6a3f56b0d9dd46ac7649f9be1fd3133978b232d /app-admin
parentFixed digests (diff)
downloadoverlay-75325fffe15c484b5173513bea0bba4657e4aee0.tar.gz
overlay-75325fffe15c484b5173513bea0bba4657e4aee0.tar.bz2
overlay-75325fffe15c484b5173513bea0bba4657e4aee0.zip
Added w-c-1.50.2
svn path=/; revision=550
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.50.2.ebuild b/app-admin/webapp-config/webapp-config-1.50.2.ebuild
new file mode 100644
index 0000000..8d2aeab
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.50.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils distutils
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://www.gunnarwrobel.de/downloads/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+S=${WORKDIR}/${PF}
+
+DEPEND=""
+
+src_install() {
+
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils_src_install --install-scripts="/usr/sbin"
+
+ dodir /etc/vhosts
+ cp config/webapp-config ${D}/etc/vhosts/
+ keepdir /usr/share/webapps
+ dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
+ doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
+}
+
+pkg_postinst() {
+ echo
+ einfo "Now that you have upgraded webapp-config, you **must** update your"
+ einfo "config files in /etc/vhosts/webapp-config before you emerge any"
+ einfo "packages that use webapp-config."
+ echo
+ epause 5
+}