summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-07-25 06:07:33 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-07-25 06:07:33 +0000
commitc0034ff3dd0b23934cb43ec090c5aa3fe0ee814b (patch)
tree826e843731c000056e7e1770b1d603fdb575a480 /app-emacs/muse/muse-3.01.90.ebuild
parentAdded EaseXML ebuild (diff)
downloadoverlay-c0034ff3dd0b23934cb43ec090c5aa3fe0ee814b.tar.gz
overlay-c0034ff3dd0b23934cb43ec090c5aa3fe0ee814b.tar.bz2
overlay-c0034ff3dd0b23934cb43ec090c5aa3fe0ee814b.zip
Updated muse mode ebuild
svn path=/; revision=160
Diffstat (limited to 'app-emacs/muse/muse-3.01.90.ebuild')
-rw-r--r--app-emacs/muse/muse-3.01.90.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/muse/muse-3.01.90.ebuild b/app-emacs/muse/muse-3.01.90.ebuild
new file mode 100644
index 0000000..6082095
--- /dev/null
+++ b/app-emacs/muse/muse-3.01.90.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Muse-mode is similar to EmacsWikiMode, but more focused on publishing to various formats."
+HOMEPAGE="http://www.mwolson.org/projects/MuseMode.html"
+SRC_URI="http://download.gna.org/muse-el/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50muse-mode-gentoo.el
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ make lisp
+}
+
+src_install() {
+ dodoc README
+ cp -r examples ${D}/usr/share/doc/${PF}/
+ mkdir -p ${D}/usr/share/${PF}/
+ cp -r contrib experimental scripts ${D}/usr/share/${PF}/
+ elisp-install ${PN} lisp/*.el lisp/*.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/muse-mode.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}