summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-09-13 21:31:42 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-09-13 21:31:42 +0000
commit95ed44634a26fd80ab180164bd325bb1c88dbf5b (patch)
treed7a06f8825359d8da2be954b5459e52275a8c58a /app-emacs/muse
parentFixed digests (diff)
downloadoverlay-95ed44634a26fd80ab180164bd325bb1c88dbf5b.tar.gz
overlay-95ed44634a26fd80ab180164bd325bb1c88dbf5b.tar.bz2
overlay-95ed44634a26fd80ab180164bd325bb1c88dbf5b.zip
muse latest added again
svn path=/; revision=392
Diffstat (limited to 'app-emacs/muse')
-rw-r--r--app-emacs/muse/muse-3.01.99.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/muse/muse-3.01.99.ebuild b/app-emacs/muse/muse-3.01.99.ebuild
new file mode 100644
index 0000000..c5ffd11
--- /dev/null
+++ b/app-emacs/muse/muse-3.01.99.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Muse-mode is similar to EmacsWikiMode, but more focused on publishing to various formats."
+HOMEPAGE="http://www.mwolson.org/projects/MuseMode.html"
+SRC_URI="http://www.mwolson.org/static/dist/muse-latest.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50muse-mode-gentoo.el
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ make lisp
+}
+
+src_install() {
+ dodoc README
+ cp -r examples ${D}/usr/share/doc/${PF}/
+ mkdir -p ${D}/usr/share/${PF}/
+ cp -r contrib experimental scripts ${D}/usr/share/${PF}/
+ elisp-install ${PN} lisp/*.el lisp/*.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/muse-mode.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}