summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-07-23 07:51:09 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-07-23 07:51:09 +0000
commit98637ed2acb746e64f8b2280c32f0b1d8f8e90ae (patch)
treebe2853117fa2748ef041f0f765df616bac0d7bf3 /app-emacs/muse
parentForgot makedir (diff)
downloadoverlay-98637ed2acb746e64f8b2280c32f0b1d8f8e90ae.tar.gz
overlay-98637ed2acb746e64f8b2280c32f0b1d8f8e90ae.tar.bz2
overlay-98637ed2acb746e64f8b2280c32f0b1d8f8e90ae.zip
Added muse-latest again
svn path=/; revision=153
Diffstat (limited to 'app-emacs/muse')
-rw-r--r--app-emacs/muse/muse-3.02.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/muse/muse-3.02.ebuild b/app-emacs/muse/muse-3.02.ebuild
new file mode 100644
index 0000000..0114140
--- /dev/null
+++ b/app-emacs/muse/muse-3.02.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit elisp
+
+MYP=${PN}-latest
+
+IUSE=""
+
+DESCRIPTION="Muse-mode is similar to EmacsWikiMode, but more focused on publishing to various formats."
+HOMEPAGE="http://www.mwolson.org/projects/MuseMode.html"
+SRC_URI="http://www.mwolson.org/static/dist/muse/${MYP}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50muse-mode-gentoo.el
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ make lisp
+}
+
+src_install() {
+ dodoc README
+ cp -r examples ${D}/usr/share/doc/${PF}/
+ mkdir -p ${D}/usr/share/${PF}/
+ cp -r contrib experimental scripts ${D}/usr/share/${PF}/
+ elisp-install ${PN} lisp/*.el lisp/*.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/muse-mode.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}