summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-06-11 20:18:52 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-06-11 20:18:52 +0000
commitf71c1734b6cb3bb43eff8b93d1e97aeb0da9b323 (patch)
treed048795c2a0013637192d6ec01be8b16965d7f13 /app-emacs/muse
parentNeed my own repository (diff)
downloadoverlay-f71c1734b6cb3bb43eff8b93d1e97aeb0da9b323.tar.gz
overlay-f71c1734b6cb3bb43eff8b93d1e97aeb0da9b323.tar.bz2
overlay-f71c1734b6cb3bb43eff8b93d1e97aeb0da9b323.zip
First muse draft ebuild
svn path=/; revision=108
Diffstat (limited to 'app-emacs/muse')
-rw-r--r--app-emacs/muse/muse-2.9.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/muse/muse-2.9.9.ebuild b/app-emacs/muse/muse-2.9.9.ebuild
new file mode 100644
index 0000000..b454c23
--- /dev/null
+++ b/app-emacs/muse/muse-2.9.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Muse-mode is similar to EmacsWikiMode, but more focused on publishing to various formats."
+HOMEPAGE="http://www.mwolson.org/projects/MuseMode.html"
+SRC_URI="http://www.mwolson.org/static/dist/muse-latest.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50muse-mode-gentoo.el
+
+S="${WORKDIR}"
+
+src_compile() {
+ elisp-compile *.el || die
+}
+
+src_install() {
+ dodoc README examples
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/muse-mode.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}