summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2004-09-23 19:58:50 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2004-09-23 19:58:50 +0000
commitc9389976abce96118b87c54dc41ff6da6969da5c (patch)
tree73e8ebec4fbedada75851ee0ce857a36d05dac01 /app-emacs/rnc-mode/rnc-mode-1.0.3_beta.ebuild
parentFinal knowledgeTree ebuild (diff)
downloadoverlay-c9389976abce96118b87c54dc41ff6da6969da5c.tar.gz
overlay-c9389976abce96118b87c54dc41ff6da6969da5c.tar.bz2
overlay-c9389976abce96118b87c54dc41ff6da6969da5c.zip
Added the emacs rnc-mode
svn path=/; revision=55
Diffstat (limited to 'app-emacs/rnc-mode/rnc-mode-1.0.3_beta.ebuild')
-rw-r--r--app-emacs/rnc-mode/rnc-mode-1.0.3_beta.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/rnc-mode/rnc-mode-1.0.3_beta.ebuild b/app-emacs/rnc-mode/rnc-mode-1.0.3_beta.ebuild
new file mode 100644
index 0000000..62e9b7a
--- /dev/null
+++ b/app-emacs/rnc-mode/rnc-mode-1.0.3_beta.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="An emacs mode for editing Relax NG compact schema files."
+HOMEPAGE="http://www.pantor.com/"
+SRC_URI="http://www.pantor.com/RncMode-1_0b3.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50rnc-mode-gentoo.el
+S="${WORKDIR}"
+
+src_compile() {
+ elisp-compile *.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/rnc-mode.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}