summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-08-08 17:59:26 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-08-08 17:59:26 +0000
commite4ede9a4d8659ec67fbc224cf1262e97095cf5b2 (patch)
tree6233da541800a38902ac7ccec6dcdd36ae441358 /app-emacs
parentStupid typo (diff)
downloadoverlay-e4ede9a4d8659ec67fbc224cf1262e97095cf5b2.tar.gz
overlay-e4ede9a4d8659ec67fbc224cf1262e97095cf5b2.tar.bz2
overlay-e4ede9a4d8659ec67fbc224cf1262e97095cf5b2.zip
New planner ebuild
svn path=/; revision=277
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/muse/muse-3.01.ebuild3
-rw-r--r--app-emacs/planner/planner-3.99.ebuild35
2 files changed, 37 insertions, 1 deletions
diff --git a/app-emacs/muse/muse-3.01.ebuild b/app-emacs/muse/muse-3.01.ebuild
index b94e16f..43e5924 100644
--- a/app-emacs/muse/muse-3.01.ebuild
+++ b/app-emacs/muse/muse-3.01.ebuild
@@ -13,7 +13,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-DEPEND="virtual/emacs"
+DEPEND="virtual/emacs
+ app-emacs/httpd"
SITEFILE=50muse-mode-gentoo.el
diff --git a/app-emacs/planner/planner-3.99.ebuild b/app-emacs/planner/planner-3.99.ebuild
new file mode 100644
index 0000000..9fc2e8f
--- /dev/null
+++ b/app-emacs/planner/planner-3.99.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/planner/planner-3.26.ebuild,v 1.3 2005/07/01 19:49:37 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="Maintain a local Wiki using Emacs-friendly markup"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki/PlannerMode"
+
+# Upstream sources are not reliably available, so we use the Debian
+# project's source archives
+
+SRC_URI="http://www.mwolson.org/static/dist/planner-muse-latest.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+DEPEND="app-emacs/muse
+ sys-apps/texinfo"
+
+SITEFILE=80planner-gentoo.el
+
+S=${WORKDIR}/planner-muse
+
+src_compile() {
+ elisp-compile *.el
+ makeinfo planner-el.texi || die
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ dodoc ChangeLog.* PLANNER-README
+ doinfo planner-el.info*
+}