summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-02-23 07:35:21 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-02-23 07:35:21 +0000
commitdfe4b68745e51a5109801a52361f2be5dcca2e25 (patch)
tree411c0b7eb2d61b89ca92f4a20edef89d0aa6f4ec /app-office/ledger/ledger-2.4.1.ebuild
parentUpdated ledger to 2.4.1 (diff)
downloadoverlay-dfe4b68745e51a5109801a52361f2be5dcca2e25.tar.gz
overlay-dfe4b68745e51a5109801a52361f2be5dcca2e25.tar.bz2
overlay-dfe4b68745e51a5109801a52361f2be5dcca2e25.zip
Forgot to add new ebuild
svn path=/testing/; revision=672
Diffstat (limited to 'app-office/ledger/ledger-2.4.1.ebuild')
-rw-r--r--app-office/ledger/ledger-2.4.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-office/ledger/ledger-2.4.1.ebuild b/app-office/ledger/ledger-2.4.1.ebuild
new file mode 100644
index 0000000..41c5bbe
--- /dev/null
+++ b/app-office/ledger/ledger-2.4.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils elisp
+
+DESCRIPTION="Ledger is an command-line accounting tool that provides double-entry accounting with a minimum of frills, and yet with a maximum of expressiveness and flexibility."
+HOMEPAGE="http://www.newartisans.com/software.html"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="NewArtisans"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="emacs debug gnuplot ofx"
+
+DEPEND=" dev-libs/gmp
+ dev-libs/libpcre
+ ofx? (>=dev-libs/libofx-0.7
+ dev-libs/expat
+ )
+ emacs? (app-editors/emacs
+ )
+ gnuplot?(media-gfx/gnuplot
+ )"
+
+SITEFILE=50ledger-mode-gentoo.el
+
+src_compile() {
+
+ local myconf
+ use ofx && myconf="${myconf} --enable-xml"
+ use ofx && myconf="${myconf} --enable-ofx"
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf} || die "Configure failed!"
+
+ emake || die "Make failed!"
+
+ use emacs && elisp_src_compile
+}
+
+
+src_install() {
+
+ dodoc sample.dat README ledger.pdf
+
+ ## One script uses vi, the outher the Finance perl module
+ ## Did not add more use flags though
+ insinto /usr/share/${P}
+ doins scripts/entry scripts/getquote scripts/bal scripts/bal-huquq
+
+ if use emacs; then
+ elisp_src_install
+ fi
+
+ einstall || die "Installation failed!"
+
+ if use gnuplot; then
+ mv scripts/report ledger-report
+ dobin ledger-report
+ fi
+}
+