summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-11-17 17:26:17 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-11-17 17:26:17 +0000
commit0b2f5c9d785603d388a207ca84ef0df524eb1d0f (patch)
treed27ac23df73e996a0435714782d5a794bb2d5530 /dev-python/python-fuse/python-fuse-2.3.ebuild
parentFixed digests (diff)
downloadoverlay-0b2f5c9d785603d388a207ca84ef0df524eb1d0f.tar.gz
overlay-0b2f5c9d785603d388a207ca84ef0df524eb1d0f.tar.bz2
overlay-0b2f5c9d785603d388a207ca84ef0df524eb1d0f.zip
Tried to correct ebuild
svn path=/; revision=536
Diffstat (limited to 'dev-python/python-fuse/python-fuse-2.3.ebuild')
-rw-r--r--dev-python/python-fuse/python-fuse-2.3.ebuild19
1 files changed, 16 insertions, 3 deletions
diff --git a/dev-python/python-fuse/python-fuse-2.3.ebuild b/dev-python/python-fuse/python-fuse-2.3.ebuild
index 07631ca..a635bd1 100644
--- a/dev-python/python-fuse/python-fuse-2.3.ebuild
+++ b/dev-python/python-fuse/python-fuse-2.3.ebuild
@@ -17,6 +17,8 @@ DEPEND="|| (sys-fs/fuse >=virtual/linux-sources-2.6.14)"
S=${WORKDIR}/${PN}
+PATCH_SETUP="no"
+
pkg_setup() {
linux-info_pkg_setup
@@ -25,8 +27,8 @@ pkg_setup() {
if [ ${CURRENT} -ge 20614 ]; then
- ebegin "Checking for kernel FUSE support"
- linux_chkconfig_present CONFIG_FUSE_FS
+ ebegin "Checking for kernel-${CURRENT} FUSE support"
+ linux_chkconfig_present FUSE_FS
eend $?
if [[ $? -ne 0 ]] ; then
@@ -39,9 +41,20 @@ pkg_setup() {
ewarn " <*> Filesystem in Userspace support"
ewarn
ewarn "and recompile your kernel if you want this package to work with this kernel"
- epause 5
+ edie
fi
+ PATCH_SETUP="yes"
+
+ fi
+}
+
+src_unpack() {
+
+ unpack ${A} && cd ${S}
+
+ if [ ${PATCH_SETUP}=="yes" ]; then
+ epatch ${FILESDIR}/kernel-fuse.patch
fi
}