summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-02-10 18:55:00 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-02-10 18:55:00 +0000
commit818c37aa08df03326ef7efa188282e44da4d8403 (patch)
tree3c1d2b7242bc7ef1dec212a94fa63dfb3674aebe /media-sound/picard
parentAnother info file (diff)
parentMakefiles need to be available in each subtree (diff)
downloadoverlay-818c37aa08df03326ef7efa188282e44da4d8403.tar.gz
overlay-818c37aa08df03326ef7efa188282e44da4d8403.tar.bz2
overlay-818c37aa08df03326ef7efa188282e44da4d8403.zip
Moved picard ebuild over to stable
svn path=/stable/; revision=667
Diffstat (limited to 'media-sound/picard')
-rw-r--r--media-sound/picard/Manifest2
-rw-r--r--media-sound/picard/files/digest-picard-0.6.01
-rw-r--r--media-sound/picard/picard-0.6.0.ebuild49
3 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/picard/Manifest b/media-sound/picard/Manifest
new file mode 100644
index 0000000..3cb0ef8
--- /dev/null
+++ b/media-sound/picard/Manifest
@@ -0,0 +1,2 @@
+MD5 997907fa6a8d9d878177b3d71fc5e505 files/digest-picard-0.6.0 64
+MD5 c054e0be1c4ce33038226ad548a6cee0 picard-0.6.0.ebuild 1301
diff --git a/media-sound/picard/files/digest-picard-0.6.0 b/media-sound/picard/files/digest-picard-0.6.0
new file mode 100644
index 0000000..c2c32c0
--- /dev/null
+++ b/media-sound/picard/files/digest-picard-0.6.0
@@ -0,0 +1 @@
+MD5 82c2da853ba4c5a0ab8e1baf3fb494eb picard-0.6.0.tar.gz 234607
diff --git a/media-sound/picard/picard-0.6.0.ebuild b/media-sound/picard/picard-0.6.0.ebuild
new file mode 100644
index 0000000..a0c14d1
--- /dev/null
+++ b/media-sound/picard/picard-0.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="The PicardTagger is the next generation MusicBrainzTagger."
+HOMEPAGE="http://wiki.musicbrainz.org/PicardTagger"
+SRC_URI="https://helixcommunity.org/download.php/1791/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4.0
+ >=dev-python/wxpython-2.6.1.0
+ =media-libs/musicbrainz-2.1.1*
+ =media-libs/tunepimp-0.4.2
+ dev-python/python-musicbrainz
+ >=dev-python/ctypes-0.9
+ "
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ if ! built_with_use dev-python/wxpython unicode ; then
+ eerror "Dependency dev-python/wxpython must be intalled with USE=\"unicode\""
+ die "Broken depencency"
+ fi
+ if ! built_with_use media-libs/tunepimp python; then
+ eerror "Dependency media-libs/tunepimp must be installed with USE=\"python\""
+ die "Broken dependency"
+ fi
+}
+
+src_install() {
+ dodir /usr/share
+ cp -vr ${P} ${D}/usr/share/${P} || die
+ dodir /usr/bin
+ dosym /usr/share/${P}/tagger.py /usr/bin/tagger.py
+ dosym /usr/share/${P}/tagger.py /usr/bin/picard-tagger.py
+}
+
+pkg_postinst() {
+ einfo "You should set the environment variable BROWSER to something like"
+ einfo "\"firefox '%s' &\" to let python know which browser to use."
+}
+