summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-01-29 14:56:06 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-01-29 14:56:06 +0000
commita8eafddb3bd91372d50b1229348cbd52d6e87708 (patch)
tree390a6c2c3c4b12edf2946c501070a7fcfbb38ecc /media-sound/picard
parentMore restructuring. (diff)
downloadoverlay-a8eafddb3bd91372d50b1229348cbd52d6e87708.tar.gz
overlay-a8eafddb3bd91372d50b1229348cbd52d6e87708.tar.bz2
overlay-a8eafddb3bd91372d50b1229348cbd52d6e87708.zip
Added kflickr and picard to my testing overlay
svn path=/testing/; revision=645
Diffstat (limited to 'media-sound/picard')
-rw-r--r--media-sound/picard/Manifest2
-rw-r--r--media-sound/picard/files/digest-picard-0.6.01
-rw-r--r--media-sound/picard/picard-0.6.0.ebuild47
3 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/picard/Manifest b/media-sound/picard/Manifest
new file mode 100644
index 0000000..8746835
--- /dev/null
+++ b/media-sound/picard/Manifest
@@ -0,0 +1,2 @@
+MD5 997907fa6a8d9d878177b3d71fc5e505 files/digest-picard-0.6.0 64
+MD5 2287d6c7464a121ef91c5d9f0a517b45 picard-0.6.0.ebuild 1199
diff --git a/media-sound/picard/files/digest-picard-0.6.0 b/media-sound/picard/files/digest-picard-0.6.0
new file mode 100644
index 0000000..c2c32c0
--- /dev/null
+++ b/media-sound/picard/files/digest-picard-0.6.0
@@ -0,0 +1 @@
+MD5 82c2da853ba4c5a0ab8e1baf3fb494eb picard-0.6.0.tar.gz 234607
diff --git a/media-sound/picard/picard-0.6.0.ebuild b/media-sound/picard/picard-0.6.0.ebuild
new file mode 100644
index 0000000..8e05e0a
--- /dev/null
+++ b/media-sound/picard/picard-0.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="The PicardTagger is the next generation MusicBrainzTagger."
+HOMEPAGE="http://wiki.musicbrainz.org/PicardTagger"
+SRC_URI="https://helixcommunity.org/download.php/1791/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4.0
+ >=dev-python/wxpython-2.6.1.0
+ =media-libs/musicbrainz-2.1.1*
+ python-musicbrainz
+ media-libs/tunepimp
+ "
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ if ! built_with_use dev-python/wxpython unicode ; then
+ eerror "Dependency dev-python/wxpython must be intalled with USE=\"unicode\""
+ die "Broken depencency"
+ fi
+ if ! built_with_use media-libs/tunepimp python; then
+ eerror "Dependency media-libs/tunepimp must be installed with USE=\"python\""
+ die "Broken dependency"
+ fi
+}
+
+src_install() {
+ dodir /usr/share
+ cp -vr ${P} ${D}/usr/share/${P} || die
+ dodir /usr/bin
+ dosym /usr/share/${P}/tagger.py /usr/bin/tagger.py
+}
+
+pkg_postinst() {
+ einfo "You should set the environment variable BROWSER to something like"
+ einfo "\"firefox '%s' &\" to let python know which browser to use."
+}
+