summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-01-14 20:51:47 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-01-14 20:51:47 +0000
commit6723cf7219bbbe5db2f5fdaa16428ce505787d8e (patch)
tree4ad17483ad209954dcec91077cfec08a9325baf3 /sci-biology
parentScripts and nntprss (diff)
downloadoverlay-6723cf7219bbbe5db2f5fdaa16428ce505787d8e.tar.gz
overlay-6723cf7219bbbe5db2f5fdaa16428ce505787d8e.tar.bz2
overlay-6723cf7219bbbe5db2f5fdaa16428ce505787d8e.zip
Added bioensembl ebuild. Seems to work
svn path=/; revision=73
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bioensembl/Manifest3
-rw-r--r--sci-biology/bioensembl/bioensembl-27.ebuild46
-rw-r--r--sci-biology/bioensembl/files/Makefile.PL10
-rw-r--r--sci-biology/bioensembl/files/digest-bioensembl-270
4 files changed, 59 insertions, 0 deletions
diff --git a/sci-biology/bioensembl/Manifest b/sci-biology/bioensembl/Manifest
new file mode 100644
index 0000000..26c6901
--- /dev/null
+++ b/sci-biology/bioensembl/Manifest
@@ -0,0 +1,3 @@
+MD5 481ec341f0eb754dffb4a155fac35e32 bioensembl-27.ebuild 893
+MD5 1829efe7f24eb03244cb7f183f9aa491 files/Makefile.PL 311
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-bioensembl-27 0
diff --git a/sci-biology/bioensembl/bioensembl-27.ebuild b/sci-biology/bioensembl/bioensembl-27.ebuild
new file mode 100644
index 0000000..f8c6640
--- /dev/null
+++ b/sci-biology/bioensembl/bioensembl-27.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioperl/bioperl-1.4.ebuild,v 1.4 2005/01/09 16:41:48 ribosome Exp $
+
+inherit cvs perl-module
+
+CATEGORY="sci-biology"
+
+DESCRIPTION="additional perl modules fpr bioperl that can be used to easily access the ensembl database"
+HOMEPAGE="http://www.ensembl.org/"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+ECVS_LOCALNAME="EnsEMBL"
+ECVS_SERVER="cvsro.sanger.ac.uk:/cvsroot/CVSmaster"
+ECVS_MODULE="ensembl/modules/Bio/EnsEMBL"
+ECVS_BRANCH="branch-ensembl-27"
+ECVS_USER="cvsuser"
+ECVS_PASS="CVSUSER"
+
+
+DEPEND="sci-biology/bioperl-1.4"
+
+src_unpack()
+{
+ cvs_src_unpack
+
+ cp ${FILESDIR}/Makefile.PL ${WORKDIR}/
+}
+
+src_compile()
+{
+ cd ${WORKDIR}
+
+ perl-module_src_compile
+}
+
+src_install()
+{
+ cd ${WORKDIR}
+
+ perl-module_src_install
+}
diff --git a/sci-biology/bioensembl/files/Makefile.PL b/sci-biology/bioensembl/files/Makefile.PL
new file mode 100644
index 0000000..fdf0c0d
--- /dev/null
+++ b/sci-biology/bioensembl/files/Makefile.PL
@@ -0,0 +1,10 @@
+use ExtUtils::MakeMaker 5.0;
+
+WriteMakefile(
+ NAME => "Bio::EnsEMBL",
+ VERSION => "27",
+ AUTHOR => "Sanger Center (ensembl-dev@ebi.ac.uk)",
+ ABSTRACT => "BioPerl modules to access ensembl",
+ INSTALLDIRS => "vendor",
+ PMLIBDIRS => [ "EnsEMBL" ]
+ );
diff --git a/sci-biology/bioensembl/files/digest-bioensembl-27 b/sci-biology/bioensembl/files/digest-bioensembl-27
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/sci-biology/bioensembl/files/digest-bioensembl-27