summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-01-16 17:23:16 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-01-16 17:23:16 +0000
commit83e162ab06ee2b9fcc49082a493cd02a44b17ef4 (patch)
tree9abf55deeb1916b4e1407478db6965af039ec489 /sci-biology
parentFinal fixes after rename. (diff)
downloadoverlay-83e162ab06ee2b9fcc49082a493cd02a44b17ef4.tar.gz
overlay-83e162ab06ee2b9fcc49082a493cd02a44b17ef4.tar.bz2
overlay-83e162ab06ee2b9fcc49082a493cd02a44b17ef4.zip
Added the repbase ebuild
svn path=/; revision=78
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/ensembl-perl/ensembl-perl-27.ebuild3
-rw-r--r--sci-biology/repbase/Manifest3
-rwxr-xr-xsci-biology/repbase/files/clean56
-rw-r--r--sci-biology/repbase/files/digest-repbase-9.121
-rw-r--r--sci-biology/repbase/repbase-9.12.ebuild65
5 files changed, 126 insertions, 2 deletions
diff --git a/sci-biology/ensembl-perl/ensembl-perl-27.ebuild b/sci-biology/ensembl-perl/ensembl-perl-27.ebuild
index 35c0e24..943dd18 100644
--- a/sci-biology/ensembl-perl/ensembl-perl-27.ebuild
+++ b/sci-biology/ensembl-perl/ensembl-perl-27.ebuild
@@ -1,6 +1,5 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioperl/bioperl-1.4.ebuild,v 1.4 2005/01/09 16:41:48 ribosome Exp $
inherit cvs perl-module
@@ -9,7 +8,7 @@ CATEGORY="sci-biology"
DESCRIPTION="Additional perl modules for bioperl that can be used to easily access the EnsEMBL database"
HOMEPAGE="http://www.ensembl.org/"
-LICENSE="Artistic GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
diff --git a/sci-biology/repbase/Manifest b/sci-biology/repbase/Manifest
new file mode 100644
index 0000000..3b07b4c
--- /dev/null
+++ b/sci-biology/repbase/Manifest
@@ -0,0 +1,3 @@
+MD5 3fe26fedb0e74c07c1f521a8e280f82b repbase-9.12.ebuild 1456
+MD5 5de6ba25014bec88b60fa472c4b69a91 files/clean 1120
+MD5 6d171b2224c472ad2ab93a3033b09c96 files/digest-repbase-9.12 70
diff --git a/sci-biology/repbase/files/clean b/sci-biology/repbase/files/clean
new file mode 100755
index 0000000..b681d52
--- /dev/null
+++ b/sci-biology/repbase/files/clean
@@ -0,0 +1,56 @@
+#!/usr/bin/perl -w
+
+use strict;
+
+my $name="";
+my $sequence="";
+my $infile = $ARGV[0];
+my $outfile = $ARGV[1];
+
+open(LIB, $infile);
+
+open(CLIB, ">", $outfile);
+
+while (<LIB>)
+{
+ if (m/^>/)
+ {
+ if ($sequence eq "" and not $name eq "")
+ {
+ print "---------------------------------------------------------------------------------------\n";
+ print "Empty sequence: " . $name . "\n";
+ }
+ else
+ {
+ if ($sequence =~ m/^[ACGTNWSYRMHKXDVB]*$/)
+ {
+ $sequence =~ s/[WSYRMHKXDVB]/N/g;
+ if (not $sequence =~ m/NNNN/)
+ {
+ print CLIB $name;
+ print CLIB $sequence . "\n";
+ }
+ else
+ {
+ print "---------------------------------------------------------------------------------------\n";
+ print "Too many N's: " . $name;
+ }
+ }
+ else
+ {
+ print "---------------------------------------------------------------------------------------\n";
+ print "Invalid entry: " . $name;
+ $sequence =~ s/[ACGTN]//g;
+ print "Reduced sequence:\n";
+ print $sequence . "\n";
+ }
+ $sequence = "";
+ }
+ $name = $_;
+ }
+ else
+ {
+ $sequence .= uc($_);
+ $sequence =~ s/\n//g;
+ }
+}
diff --git a/sci-biology/repbase/files/digest-repbase-9.12 b/sci-biology/repbase/files/digest-repbase-9.12
new file mode 100644
index 0000000..3188ee7
--- /dev/null
+++ b/sci-biology/repbase/files/digest-repbase-9.12
@@ -0,0 +1 @@
+MD5 fdf7cf4befd28b6b902da0f4a9263c72 RepBase9.12.fasta.tar.gz 3271264
diff --git a/sci-biology/repbase/repbase-9.12.ebuild b/sci-biology/repbase/repbase-9.12.ebuild
new file mode 100644
index 0000000..b9a5f35
--- /dev/null
+++ b/sci-biology/repbase/repbase-9.12.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+CATEGORY="sci-biology"
+
+MY_P="RepBase${PV}.fasta"
+
+DESCRIPTION="A database of repetetive genetic elements in various organisms."
+HOMEPAGE="http://www.girinst.org"
+SRC_URI="${MY_P}.tar.gz"
+
+LICENSE="repbase-agreement"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT="fetch"
+
+REPBASELOC="${HOMEPAGE}/server/RepBase/"
+
+REPLIBRARIES="
+angrep.ref=repeat_lib_A.gambiae
+cbrrep.ref=repeat_lib_C.briggsae
+celrep.ref=repeat_lib_C.elegans
+drorep.ref=repeat_lib_D.melanogaster
+fugrep.ref=repeat_lib_F.rubripes
+humrep.ref=repeat_lib_H.sapiens
+prirep.ref=repeat_lib_P.troglodyte
+rodrep.ref=repeat_lib_M.musculus
+rodrep.ref=repeat_lib_R.norvegicus
+zebrep.ref=repeat_lib_D.rerio
+"
+
+pkg_nofetch()
+{
+ einfo "Please download ${SRC_URI}"
+ einfo "from ${REPBASELOC} and place it in ${DISTDIR}."
+ einfo "You will need to register as an academic user at"
+ einfo "${HOMEPAGE} in order to be"
+ einfo "allowed to download the file."
+}
+
+src_compile()
+{
+ cp ${FILESDIR}/clean ${WORKDIR}
+ cd ${WORKDIR}
+ for lib in ${REPLIBRARIES}
+ do
+ einfo Cleaning library file ${lib/=*/} to ${lib/*=/}
+ ./clean ${MY_P}/${lib/=*/} ${lib/*=/}
+ done
+}
+
+src_install()
+{
+ cd ${WORKDIR}
+ install -m 644 -d ${D}/usr/share/${P}/
+ for lib in ${REPLIBRARIES}
+ do
+ install -m 644 ${lib/*=/} ${D}/usr/share/${P}/
+ done
+}