summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-10-27 08:02:39 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-10-27 08:02:39 +0000
commit7733b97f466c701556a4d7bf9f2b9ded8ca98a6c (patch)
tree22f2d57b4a7ef659bd6ffa6448f29c8366fc7674 /www-apps
parentFixed digests (diff)
downloadoverlay-7733b97f466c701556a4d7bf9f2b9ded8ca98a6c.tar.gz
overlay-7733b97f466c701556a4d7bf9f2b9ded8ca98a6c.tar.bz2
overlay-7733b97f466c701556a4d7bf9f2b9ded8ca98a6c.zip
Some fixes to the claroline ebuild
svn path=/; revision=474
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/claroline/claroline-1.7.0.ebuild10
-rw-r--r--www-apps/claroline/files/postinstall-en.txt26
-rw-r--r--www-apps/xrms/xrms-2005.05.07.ebuild9
3 files changed, 17 insertions, 28 deletions
diff --git a/www-apps/claroline/claroline-1.7.0.ebuild b/www-apps/claroline/claroline-1.7.0.ebuild
index b938461..6387e7f 100644
--- a/www-apps/claroline/claroline-1.7.0.ebuild
+++ b/www-apps/claroline/claroline-1.7.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit webapp
+inherit webapp depend.php
MYP=${PN}${PV//./}
@@ -19,6 +19,12 @@ RDEPEND="net-www/apache
S=${WORKDIR}/${MYP}
+pkg_setup() {
+
+ require_php_with_use tokenizer
+
+}
+
src_install() {
webapp_src_preinst
@@ -28,7 +34,7 @@ src_install() {
## Install documentation
DOCS="CREDITS.txt INSTALL.txt README.txt"
dodoc ${DOCS}
-
+
## Install application
cp -R . ${D}/${MY_HTDOCSDIR}
diff --git a/www-apps/claroline/files/postinstall-en.txt b/www-apps/claroline/files/postinstall-en.txt
index 41d3c37..ad607a5 100644
--- a/www-apps/claroline/files/postinstall-en.txt
+++ b/www-apps/claroline/files/postinstall-en.txt
@@ -1,15 +1,8 @@
The claroline install instructions request setting your php.ini file
to the following values.
- short_open_tag = On
- register_globals = On
safe_mode = Off
- magic_quotes_gpc = On
magic_quotes_runtime = Off
- error_reporting = E_ALL & ~E_NOTICE (*)
-
-(register_globals is turned off in php.ini by default and definitely
-needs to be turned on)
------------------------------------------------------------------------
@@ -45,22 +38,3 @@ Claroline will not work if you install it with the
VHOST_LINK_TYPE="soft" setting in your /etc/vhosts/webapp-config
file. So don't complain...
-Setting "register_globals = On" in the php.ini is generally not
-considered to be safe. From the documentation in php.ini:
-
-; You should do your best to write your scripts so that they do not require
-; register_globals to be on; Using form variables as globals can easily lead
-; to possible security problems, if the code is not very well thought of.
-
-In addition Claroline wants its whole web directory to be owned by the
-webserver which many administrators might consider as unsafe. During
-installation Claroline will create several files in the directory tree.
-
-Taken together I do not believe Claroline has been written with
-security given a very high priority.
-
-So ...
-
-!! PLEASE CONSIDER THE POSSIBLE SECURITY RISKS WHEN INSTALLING
-!! CLAROLINE.
-
diff --git a/www-apps/xrms/xrms-2005.05.07.ebuild b/www-apps/xrms/xrms-2005.05.07.ebuild
index 801ff23..f43c4de 100644
--- a/www-apps/xrms/xrms-2005.05.07.ebuild
+++ b/www-apps/xrms/xrms-2005.05.07.ebuild
@@ -18,12 +18,21 @@ DEPEND="virtual/httpd-php"
S=${WORKDIR}/${PN}
+pkg_setup() {
+
+ require_php_with_use recode
+
+}
+
+
src_unpack() {
unpack ${A} && cd "${S}"
find . -type d -name CVS | xargs rm -rf
+ rm -rf include/adodb include/jpgraph*
+
}
src_install() {