summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/topgit/Manifest1
-rw-r--r--dev-util/topgit/topgit-9999.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/topgit/Manifest b/dev-util/topgit/Manifest
new file mode 100644
index 0000000..fcf4cd6
--- /dev/null
+++ b/dev-util/topgit/Manifest
@@ -0,0 +1 @@
+EBUILD topgit-9999.ebuild 614 RMD160 7aee4b8a1cad8ed5a31286cda4cabd3c336ccf1c SHA1 72adcafb5f6fa721c6b0804957749ab0e308d080 SHA256 c86c3aaee550ff431b63127a3a566f5fe9c7149cc9e49543eb9a715713b510e8
diff --git a/dev-util/topgit/topgit-9999.ebuild b/dev-util/topgit/topgit-9999.ebuild
new file mode 100644
index 0000000..07cdc6f
--- /dev/null
+++ b/dev-util/topgit/topgit-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EGIT_REPO_URI="git://repo.or.cz/topgit.git"
+inherit git bash-completion
+SRC_URI=""
+
+
+DESCRIPTION="TopGit - A different patch queue manager"
+HOMEPAGE="http://kerneltrap.org/mailarchive/git/2008/8/3/2795494"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bash-completion"
+
+DEPEND="dev-util/git"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake prefix="/usr" all || die "all"
+}
+
+src_install() {
+ emake prefix="${D}usr" install || die "install"
+ dobashcompletion contrib/tg-completion.bash ${PN}
+}