summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/muse/muse-3.01.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/muse/muse-3.01.ebuild b/app-emacs/muse/muse-3.01.ebuild
new file mode 100644
index 0000000..dc47fa0
--- /dev/null
+++ b/app-emacs/muse/muse-3.01.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Muse-mode is similar to EmacsWikiMode, but more focused on publishing to various formats."
+HOMEPAGE="http://www.mwolson.org/projects/MuseMode.html"
+SRC_URI="http://www.mwolson.org/static/dist/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50muse-mode-gentoo.el
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ # Cannot use elisp-compile here. Need to set
+ # additional options
+ /usr/bin/emacs --no-init-file --no-site-file -batch \
+ -L . --load=scripts/muse-build.el \
+ -f batch-byte-compile *.el || die
+}
+
+src_install() {
+ dodoc README
+ cp -r examples ${D}/usr/share/doc/${PF}/
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/muse-mode.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}