summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ssh-login')
-rw-r--r--app-emacs/ssh-login/Manifest5
-rw-r--r--app-emacs/ssh-login/files/50ssh-login-gentoo.el4
-rw-r--r--app-emacs/ssh-login/files/digest-ssh-login-1.91
-rw-r--r--app-emacs/ssh-login/files/semantic.cache14
-rw-r--r--app-emacs/ssh-login/info.trac2
-rw-r--r--app-emacs/ssh-login/ssh-login-1.9.ebuild36
6 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/ssh-login/Manifest b/app-emacs/ssh-login/Manifest
new file mode 100644
index 0000000..f1fd24e
--- /dev/null
+++ b/app-emacs/ssh-login/Manifest
@@ -0,0 +1,5 @@
+MD5 c8f908098c8082dc82798708aadffa89 files/50ssh-login-gentoo.el 54
+MD5 eae9cc8023fc3db913edd88ed32db912 files/digest-ssh-login-1.9 52
+MD5 b445638f576d784ec777a695b6ba8178 files/semantic.cache 364
+MD5 2d1c158223061a1126c574e114f381d9 info.trac 150
+MD5 61b1a7b03b94e6f3993f7a6239499f5c ssh-login-1.9.ebuild 720
diff --git a/app-emacs/ssh-login/files/50ssh-login-gentoo.el b/app-emacs/ssh-login/files/50ssh-login-gentoo.el
new file mode 100644
index 0000000..bd953bc
--- /dev/null
+++ b/app-emacs/ssh-login/files/50ssh-login-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; ssh-mode site-lisp configuration
+
+(require 'ssh)
diff --git a/app-emacs/ssh-login/files/digest-ssh-login-1.9 b/app-emacs/ssh-login/files/digest-ssh-login-1.9
new file mode 100644
index 0000000..5dc77ca
--- /dev/null
+++ b/app-emacs/ssh-login/files/digest-ssh-login-1.9
@@ -0,0 +1 @@
+MD5 344c0eae6d13569999806f614d537f78 ssh.el.gz 5321
diff --git a/app-emacs/ssh-login/files/semantic.cache b/app-emacs/ssh-login/files/semantic.cache
new file mode 100644
index 0000000..bfd0cc8
--- /dev/null
+++ b/app-emacs/ssh-login/files/semantic.cache
@@ -0,0 +1,14 @@
+;; Object semantic.cache
+;; SEMANTICDB Tags save file
+(semanticdb-project-database "semantic.cache"
+ :file "semantic.cache"
+ :tables (list
+ (semanticdb-table "50ssh-login-gentoo.el"
+ :file "50ssh-login-gentoo.el"
+ :pointmax 55
+ :major-mode 'emacs-lisp-mode
+ :tokens '(("ssh" include nil nil nil [40 54]))
+ :unmatched-syntax 'nil
+ )
+ )
+ )
diff --git a/app-emacs/ssh-login/info.trac b/app-emacs/ssh-login/info.trac
new file mode 100644
index 0000000..149b5d6
--- /dev/null
+++ b/app-emacs/ssh-login/info.trac
@@ -0,0 +1,2 @@
+NOTE="This is a comint-based interface for connecting to remote hosts via ssh. It features remote directory tracking via transparent ftp"
+BUG="63452"
diff --git a/app-emacs/ssh-login/ssh-login-1.9.ebuild b/app-emacs/ssh-login/ssh-login-1.9.ebuild
new file mode 100644
index 0000000..74dd440
--- /dev/null
+++ b/app-emacs/ssh-login/ssh-login-1.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Allows to use an emacs buffer for remote login"
+HOMEPAGE="http://www.splode.com/~friedman/"
+SRC_URI="http://www.gunnarwrobel.de/downloads/${PN/-login/}.el.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50ssh-login-gentoo.el
+S="${WORKDIR}"
+
+src_compile() {
+ elisp-compile *.el || die
+}
+
+src_install() {
+ elisp-install ${PN/-login/} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/ssh.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}