summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/ledger/ledger-2.3.ebuild')
-rw-r--r--app-office/ledger/ledger-2.3.ebuild98
1 files changed, 0 insertions, 98 deletions
diff --git a/app-office/ledger/ledger-2.3.ebuild b/app-office/ledger/ledger-2.3.ebuild
deleted file mode 100644
index 59d79b7..0000000
--- a/app-office/ledger/ledger-2.3.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2005 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils distutils elisp
-
-DESCRIPTION="Ledger is an command-line accounting tool that provides double-entry accounting with a minimum of frills, and yet with a maximum of expressiveness and flexibility."
-HOMEPAGE="http://www.newartisans.com/software.html"
-
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="NewArtisans"
-KEYWORDS="~x86"
-SLOT="0"
-IUSE="emacs debug gnuplot ofx python "
-
-DEPEND=" dev-libs/gmp
- dev-libs/libpcre
- ofx? (>=dev-libs/libofx-0.7
- dev-libs/expat
- )
- python? (dev-lang/python
- dev-libs/boost
- )
- emacs? (app-editors/emacs
- )
- gnuplot?(media-gfx/gnuplot
- )"
-
-SITEFILE=50ledger-mode-gentoo.el
-
-src_unpack() {
-
- unpack ${A} && cd ${S}
-
- if use ofx; then
- ## Make configure recognize expat as xml parser
- epatch ${FILESDIR}/gentoo-expat.patch
-
- ## Somehow missing from source package
- touch AUTHORS COPYING
-
- autoconf || die "Autoconf failed to rebuild configure!"
- fi
-}
-
-src_compile() {
-
- local myconf
- use ofx && myconf="${myconf} --enable-xml"
- use ofx && myconf="${myconf} --enable-ofx"
- use python && myconf="${myconf} --enable-python"
- use debug && myconf="${myconf} --enable-debug"
-
- distutils_python_version
- CPPFLAGS="-I /usr/include/python${PYVER}" econf ${myconf} || die "Configure failed!"
-
- emake || die "Make failed!"
-
- use emacs && elisp_src_compile
-
- use python && distutils_src_compile
-}
-
-
-src_install() {
-
- dodoc sample.dat README ledger.pdf
-
- mv scripts/bal ledger-bal
- mv scripts/bal-huquq ledger-bal-huquq
- dobin bal bal-huquq
-
- ## One script uses vi, the outher the Finance perl module
- ## Did not want to add more use flags
- insinto /usr/share/${P}
- doins scripts/entry scripts/getquote
-
- if use emacs; then
- elisp_src_install
- fi
-
- einstall || die "Installation failed!"
-
- if use gnuplot; then
- mv scripts/report ledger-report
- dobin ledger-report
- fi
-
- if use python; then
- distutils_src_install
- mv scripts/trend ledger-trend
- dobin ledger-trend
- dobin timeclock
- dobin scripts/to scripts/ti scripts/tc
- fi
-}
-