summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jdbm/jdbm-0.12.ebuild')
-rw-r--r--dev-java/jdbm/jdbm-0.12.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-java/jdbm/jdbm-0.12.ebuild b/dev-java/jdbm/jdbm-0.12.ebuild
deleted file mode 100644
index dea533a..0000000
--- a/dev-java/jdbm/jdbm-0.12.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit eutils java-pkg
-
-MY_P="${PN}-${PV}-src.zip"
-
-DESCRIPTION="JDBM is a transactional persistence engine for Java. It aims to be for Java what GDBM is for other languages (C/C++, Python, Perl, etc.): a fast, simple persistence engine."
-HOMEPAGE="http://jdbm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}"
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~x86"
-IUSE=""
-
-RDEPEND=">=virtual/jre-1.4"
-
-DEPEND="
->=virtual/jdk-1.4
-"
-
-src_unpack() {
-
- unpack ${MY_P}
- cd ${S}/src
-
- ## Fixes some problems in the ant build.xml
- epatch ${FILESDIR}/jdbm-0.12-build-fix.patch
-
-
-}
-
-src_compile() {
- cd ${S}/src
- ant all || die "Compilation failed!"
-}
-
-src_install() {
-
- java-pkg_dojar ${S}/src/dist/${PN}-${PV}.jar
-
-}