summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/picard/picard-0.6.0.ebuild')
-rw-r--r--media-sound/picard/picard-0.6.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/media-sound/picard/picard-0.6.0.ebuild b/media-sound/picard/picard-0.6.0.ebuild
deleted file mode 100644
index a0c14d1..0000000
--- a/media-sound/picard/picard-0.6.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils
-
-DESCRIPTION="The PicardTagger is the next generation MusicBrainzTagger."
-HOMEPAGE="http://wiki.musicbrainz.org/PicardTagger"
-SRC_URI="https://helixcommunity.org/download.php/1791/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-
-DEPEND=">=dev-lang/python-2.4.0
- >=dev-python/wxpython-2.6.1.0
- =media-libs/musicbrainz-2.1.1*
- =media-libs/tunepimp-0.4.2
- dev-python/python-musicbrainz
- >=dev-python/ctypes-0.9
- "
-
-S="${WORKDIR}"
-
-pkg_setup() {
- if ! built_with_use dev-python/wxpython unicode ; then
- eerror "Dependency dev-python/wxpython must be intalled with USE=\"unicode\""
- die "Broken depencency"
- fi
- if ! built_with_use media-libs/tunepimp python; then
- eerror "Dependency media-libs/tunepimp must be installed with USE=\"python\""
- die "Broken dependency"
- fi
-}
-
-src_install() {
- dodir /usr/share
- cp -vr ${P} ${D}/usr/share/${P} || die
- dodir /usr/bin
- dosym /usr/share/${P}/tagger.py /usr/bin/tagger.py
- dosym /usr/share/${P}/tagger.py /usr/bin/picard-tagger.py
-}
-
-pkg_postinst() {
- einfo "You should set the environment variable BROWSER to something like"
- einfo "\"firefox '%s' &\" to let python know which browser to use."
-}
-