summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/flickrfs/files/flickrfs-1.1.9.patch')
-rw-r--r--net-fs/flickrfs/files/flickrfs-1.1.9.patch104
1 files changed, 0 insertions, 104 deletions
diff --git a/net-fs/flickrfs/files/flickrfs-1.1.9.patch b/net-fs/flickrfs/files/flickrfs-1.1.9.patch
deleted file mode 100644
index 9df6566..0000000
--- a/net-fs/flickrfs/files/flickrfs-1.1.9.patch
+++ /dev/null
@@ -1,104 +0,0 @@
-diff -Naur --exclude='*.pyc' flickrfs-1.1.9/flickrapi.py flickrfs-1.1.9-mod/flickrapi.py
---- flickrfs-1.1.9/flickrapi.py 2005-11-08 15:21:57.000000000 +0100
-+++ flickrfs-1.1.9-mod/flickrapi.py 2005-11-14 22:07:26.000000000 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!python
- #
- # Flickr API implementation
- #
-diff -Naur --exclude='*.pyc' flickrfs-1.1.9/flickrfs.conf flickrfs-1.1.9-mod/flickrfs.conf
---- flickrfs-1.1.9/flickrfs.conf 1970-01-01 01:00:00.000000000 +0100
-+++ flickrfs-1.1.9-mod/flickrfs.conf 2005-11-14 21:03:03.000000000 +0100
-@@ -0,0 +1,18 @@
-+[USER]
-+
-+# for out-of-band auth inside a web browser
-+browserName : /usr/bin/firefox
-+
-+
-+#-------------------------------------------------------------------
-+
-+# It is not necessary to change these. They just identifies this as
-+# this application as flickrfs so that flickr.com can track the
-+# usage by different api's
-+
-+# API key
-+flickrAPIKey : f8aa9917a9ae5e44a87cae657924f42d
-+
-+# shared "secret"
-+flickrSecret : 3fbf7144be7eca28
-+
-diff -Naur --exclude='*.pyc' flickrfs-1.1.9/flickrfs.py flickrfs-1.1.9-mod/flickrfs.py
---- flickrfs-1.1.9/flickrfs.py 2005-11-08 22:01:39.000000000 +0100
-+++ flickrfs-1.1.9-mod/flickrfs.py 2005-11-14 21:56:16.000000000 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!python
- #@+leo-ver=4
- #@+node:@file flickrfs.py
- #===============================================================================
-@@ -58,11 +58,22 @@
- #Import flickr python api
- from flickrapi import FlickrAPI
-
--# flickr auth information
--flickrAPIKey = "f8aa9917a9ae5e44a87cae657924f42d" # API key
--flickrSecret = "3fbf7144be7eca28" # shared "secret"
--browserName = "/usr/bin/firefox" # for out-of-band auth inside a web browser
-+# Import ConfigParser
-+from ConfigParser import ConfigParser
-
-+def read_config(config_file = '/etc/flickrfs/flickrfs.conf'):
-+ defaults = {
-+ 'flickrAPIKey' : "f8aa9917a9ae5e44a87cae657924f42d", # API key
-+ 'flickrSecret' : "3fbf7144be7eca28", # shared "secret"
-+ 'browserName' : "/usr/bin/firefox",} # for out-of-band auth inside a web browser
-+
-+ config = ConfigParser(defaults)
-+ config.add_section('USER')
-+
-+ if os.access(config_file, os.R_OK):
-+ config.read(config_file)
-+
-+ return config
-
- class TransFlickr: #Transactions with flickr
- def uploadfile(self, filepath, taglist, bufData, mode):
-@@ -1141,6 +1154,12 @@
-
- #@+node:mainline
- if __name__ == '__main__':
-+
-+ config = read_config()
-+ flickrAPIKey = config.get('USER', 'flickrAPIKey')
-+ flickrSecret = config.get('USER', 'flickrSecret')
-+ browserName = config.get('USER', 'browserName')
-+
- try:
- server = Flickrfs()
- server.multithreaded = 1;
-diff -Naur --exclude='*.pyc' flickrfs-1.1.9/setup.py flickrfs-1.1.9-mod/setup.py
---- flickrfs-1.1.9/setup.py 1970-01-01 01:00:00.000000000 +0100
-+++ flickrfs-1.1.9-mod/setup.py 2005-11-14 20:23:31.000000000 +0100
-@@ -0,0 +1,20 @@
-+#!/usr/bin/env python
-+
-+import sys
-+
-+from distutils.core import setup
-+
-+# this affects the names of all the directories we do stuff with
-+sys.path.insert(0, './')
-+
-+setup(name = 'flickrfs',
-+ version = '1.1.9',
-+ description = 'A virtual filesystem that provides easy access to flickr',
-+ author = 'Manish Rai Jain',
-+ author_email = 'manishrjain@gmail.com',
-+ url = 'http://flickrfs.sourceforge.net/',
-+ py_modules = ['flickrapi'],
-+ scripts = ['flickrfs'],
-+ data_files = [('/etc/flickrfs', ['flickrfs.conf'])],
-+ license = 'GPL',
-+ )