summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/autoprime/autoprime-2.0.ebuild')
-rw-r--r--sci-biology/autoprime/autoprime-2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-biology/autoprime/autoprime-2.0.ebuild b/sci-biology/autoprime/autoprime-2.0.ebuild
new file mode 100644
index 0000000..cfac2ec
--- /dev/null
+++ b/sci-biology/autoprime/autoprime-2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /home/fsk/.cvsroot/AutoPrime/ebuilds/sci-biology/autoprime/autoprime-2.0.ebuild,v 1.1.1.1 2005/09/03 20:17:54 fsk Exp $
+
+inherit perl-module
+
+CATEGORY="sci-biology"
+
+DESCRIPTION="A command line tool to generate primers for RT-PCR"
+HOMEPAGE="http://www.autoprime.de/"
+SRC_URI="http://www.gunnarwrobel.de/downloads/AutoPrime-2.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=sci-biology/bioperl-1.4
+ >=sci-biology/repbase-9.12
+ >=sci-biology/primer3-1.0.0
+ "
+
+src_compile()
+{
+ cd ${WORKDIR}/${A/.tar.gz//}
+
+ perl-module_src_compile
+}
+
+src_install()
+{
+ cd ${WORKDIR}/${A/.tar.gz//}
+
+ perl-module_src_install
+}