summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/ensembl-perl/ensembl-perl-31.ebuild')
-rw-r--r--sci-biology/ensembl-perl/ensembl-perl-31.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-biology/ensembl-perl/ensembl-perl-31.ebuild b/sci-biology/ensembl-perl/ensembl-perl-31.ebuild
new file mode 100644
index 0000000..d00116e
--- /dev/null
+++ b/sci-biology/ensembl-perl/ensembl-perl-31.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit cvs perl-module
+
+CATEGORY="sci-biology"
+
+DESCRIPTION="Additional perl modules for bioperl that can be used to easily access the EnsEMBL database"
+HOMEPAGE="http://www.ensembl.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+ECVS_LOCALNAME="EnsEMBL"
+ECVS_SERVER="cvsro.sanger.ac.uk:/cvsroot/CVSmaster"
+ECVS_MODULE="ensembl/modules/Bio/EnsEMBL"
+ECVS_BRANCH="branch-ensembl-${PV}"
+ECVS_USER="cvsuser"
+ECVS_PASS="CVSUSER"
+
+
+DEPEND="=sci-biology/bioperl-1.4"
+
+src_unpack()
+{
+ cvs_src_unpack
+
+ cp ${FILESDIR}/Makefile.PL ${WORKDIR}/
+}
+
+src_compile()
+{
+ cd ${WORKDIR}
+
+ perl-module_src_compile
+}
+
+src_install()
+{
+ cd ${WORKDIR}
+
+ perl-module_src_install
+}