summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/repbase/repbase-10.03.ebuild')
-rw-r--r--sci-biology/repbase/repbase-10.03.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sci-biology/repbase/repbase-10.03.ebuild b/sci-biology/repbase/repbase-10.03.ebuild
new file mode 100644
index 0000000..32f0e4f
--- /dev/null
+++ b/sci-biology/repbase/repbase-10.03.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+CATEGORY="sci-biology"
+
+MY_P="RepBase${PV}.fasta"
+
+DESCRIPTION="A database of repetetive genetic elements in various organisms."
+HOMEPAGE="http://www.girinst.org"
+SRC_URI="${MY_P}.tar.gz"
+
+LICENSE="repbase-agreement"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT="fetch"
+
+REPBASELOC="${HOMEPAGE}/server/RepBase/"
+
+REPLIBRARIES="
+angrep.ref=repeat_lib_A.gambiae
+cbrrep.ref=repeat_lib_C.briggsae
+celrep.ref=repeat_lib_C.elegans
+drorep.ref=repeat_lib_D.melanogaster
+fugrep.ref=repeat_lib_F.rubripes
+humrep.ref=repeat_lib_H.sapiens
+prirep.ref=repeat_lib_P.troglodyte
+rodrep.ref=repeat_lib_M.musculus
+rodrep.ref=repeat_lib_R.norvegicus
+zebrep.ref=repeat_lib_D.rerio
+"
+
+pkg_nofetch()
+{
+ einfo "Please download ${SRC_URI}"
+ einfo "from ${REPBASELOC} and place it in ${DISTDIR}."
+ einfo "You will need to register as an academic user at"
+ einfo "${HOMEPAGE} in order to be"
+ einfo "allowed to download the file."
+}
+
+src_compile()
+{
+ cp ${FILESDIR}/clean ${WORKDIR}
+ cd ${WORKDIR}
+ for lib in ${REPLIBRARIES}
+ do
+ einfo Cleaning library file ${lib/=*/} to ${lib/*=/}
+ ./clean ${MY_P}/${lib/=*/} ${lib/*=/}
+ done
+}
+
+src_install()
+{
+ cd ${WORKDIR}
+ install -m 755 -d ${D}/usr/share/${P}/
+ for lib in ${REPLIBRARIES}
+ do
+ install -m 644 ${lib/*=/} ${D}/usr/share/${P}/
+ done
+}