summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/xrms/xrms-2005.05.07.ebuild')
-rw-r--r--www-apps/xrms/xrms-2005.05.07.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/xrms/xrms-2005.05.07.ebuild b/www-apps/xrms/xrms-2005.05.07.ebuild
new file mode 100644
index 0000000..f5338fd
--- /dev/null
+++ b/www-apps/xrms/xrms-2005.05.07.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit webapp
+
+MY_P=${P/./-}
+
+DESCRIPTION=""
+HOMEPAGE="http://xrms.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="OpenSoftware"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+
+ unpack ${A} && cd "${S}"
+
+ find . -type d -name CVS | xargs rm -rf
+
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="CHANGELOG README"
+
+ # Copy the app's main files
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ # handle documentation files
+ dodoc ${docs}
+ for doc in ${docs}; do
+ rm -f ${D}${MY_HTDOCSDIR}/${doc}
+ done
+
+ # Identify the configuration files that this app uses
+ #webapp_configfile ${MY_HTDOCSDIR}/config.inc.php
+
+ webapp_src_install
+}