summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2013-09-03 11:35:54 +0200
committerWolfram Schlich <wschlich@gentoo.org>2013-09-03 11:35:54 +0200
commit88a81f12dcda3b1deb01580e4b8dd63484955bd1 (patch)
treebf760aeeac87403546853d5123990591ec1770aa
parentversion bump, removed old versions (diff)
downloadwschlich-88a81f12dcda3b1deb01580e4b8dd63484955bd1.tar.gz
wschlich-88a81f12dcda3b1deb01580e4b8dd63484955bd1.tar.bz2
wschlich-88a81f12dcda3b1deb01580e4b8dd63484955bd1.zip
version bump
Package-Manager: portage-2.2.1
-rw-r--r--app-antivirus/skyldav/ChangeLog6
-rw-r--r--app-antivirus/skyldav/Manifest1
-rw-r--r--app-antivirus/skyldav/skyldav-0.2_rc4_p20130829.ebuild74
3 files changed, 81 insertions, 0 deletions
diff --git a/app-antivirus/skyldav/ChangeLog b/app-antivirus/skyldav/ChangeLog
index 89e6bdf..7c4eeef 100644
--- a/app-antivirus/skyldav/ChangeLog
+++ b/app-antivirus/skyldav/ChangeLog
@@ -1,3 +1,9 @@
+*skyldav-0.2_rc4_p20130829 (03 Sep 2013)
+
+ 03 Sep 2013; Wolfram Schlich <wschlich@gentoo.org>
+ +skyldav-0.2_rc4_p20130829.ebuild:
+ version bump
+
*skyldav-0.2_rc4 (25 Aug 2013)
25 Aug 2013; Wolfram Schlich <wschlich@gentoo.org>
diff --git a/app-antivirus/skyldav/Manifest b/app-antivirus/skyldav/Manifest
index ce75daa..aa9fa6f 100644
--- a/app-antivirus/skyldav/Manifest
+++ b/app-antivirus/skyldav/Manifest
@@ -1 +1,2 @@
+DIST skyldav-0.2_rc4_p20130829.tar.gz 104425 SHA256 f05e198553ff4deb60a06b4d3166bccf1099e2fcd86a180f74f9ee7069b7cdef SHA512 0961b068acb693f3225fbd0d58e29bc3346474ea05b0c513bafe12f16a8ddbe6ca6f97d833046b927cff346d4b9a64c213d4bca3199816dbfd8a63213b009a63 WHIRLPOOL 88a721d403d0f23c380b46b8b577f34434e028c63df931eb14ba27820cbd5ab953e35148bc16d2e4e6177884e9615a268a08455323c8703e867babb1f231c463
DIST skyldav-0.2rc4.tar.gz 102690 SHA256 9752520ca4b50ee181541b4decddffacd17c192bcf059e5d89d5de5485747bc3 SHA512 ed62c459907afed619df362f08b2eb565cef70b2c10f1da7f64d72a0ee2767f776387b38b50c3729eaca33ac640b827bdd1cb02f117778944c512d8902f40858 WHIRLPOOL 90cae16a26122df1db9c4d0c4ba13fa5939febdbc2d2e61ed5a0755234f3fe2ec055bcd138c7f2fd9c2ad1827b0aa3789117d755c5100c1ba1e7f5863a004e09
diff --git a/app-antivirus/skyldav/skyldav-0.2_rc4_p20130829.ebuild b/app-antivirus/skyldav/skyldav-0.2_rc4_p20130829.ebuild
new file mode 100644
index 0000000..e3dce21
--- /dev/null
+++ b/app-antivirus/skyldav/skyldav-0.2_rc4_p20130829.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit flag-o-matic linux-info linux-mod autotools-utils
+
+DESCRIPTION="Skyld AV: on-access scanning daemon for ClamAV using fanotify"
+HOMEPAGE="http://xypron.github.io/skyldav/"
+
+## github release tarball
+#MY_PV=${PV/_rc/rc}
+#MY_P="${PN}-${MY_PV}"
+#SRC_URI="https://github.com/xypron/skyldav/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+## selfmade tarball
+#MY_PVR=${PVR/_rc/rc}
+#MY_P="${PN}-${MY_PVR}"
+#SRC_URI="http://dev.gentoo.org/~wschlich/src/${CATEGORY}/${PN}/${MY_P}.tar.gz"
+
+## github commit tarball
+MY_GIT_COMMIT="49bdb5e710b5a77c38ceb87da6015afb7009f1f9"
+MY_P="xypron-${PN}-${MY_GIT_COMMIT:0:7}"
+SRC_URI="https://github.com/xypron/${PN}/tarball/${MY_GIT_COMMIT} -> ${PF}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="libnotify"
+
+RDEPEND=">=app-antivirus/clamav-0.97.8
+ sys-apps/util-linux
+ sys-libs/libcap
+ libnotify? (
+ media-libs/libcanberra[gtk]
+ x11-libs/libnotify
+ x11-libs/gtk+:2
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf-archive"
+
+## autotools-utils.eclass settings
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+DOCS=( AUTHORS NEWS README )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.2_rc4-more-syslog-messages.patch"
+ "${FILESDIR}/${PN}-0.2_rc4-conf.patch"
+ "${FILESDIR}/${PN}-0.2_rc4-examples.patch"
+ "${FILESDIR}/${PN}-0.2_rc4-sbin.patch"
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+ kernel_is ge 3 8 0 || die "Linux 3.8.0 or newer recommended"
+ CONFIG_CHECK="FANOTIFY FANOTIFY_ACCESS_PERMISSIONS"
+ check_extra_config
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with libnotify notification)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}