summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2006-07-26 21:48:55 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2006-07-26 21:48:55 +0000
commitd37101c66ab85bcd59b1be8258eedc2e02606746 (patch)
treeb73b550c34c8bbeb79e121961e19a1065d97af3b /sys-apps/915resolution/915resolution-0.5.2.ebuild
parentv4l2 cvs plugin (diff)
downloadzaheerm-d37101c66ab85bcd59b1be8258eedc2e02606746.tar.gz
zaheerm-d37101c66ab85bcd59b1be8258eedc2e02606746.tar.bz2
zaheerm-d37101c66ab85bcd59b1be8258eedc2e02606746.zip
915resolution and vbetool, needed for macbook
svn path=/; revision=10
Diffstat (limited to 'sys-apps/915resolution/915resolution-0.5.2.ebuild')
-rw-r--r--sys-apps/915resolution/915resolution-0.5.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/915resolution/915resolution-0.5.2.ebuild b/sys-apps/915resolution/915resolution-0.5.2.ebuild
new file mode 100644
index 0000000..0d2e3d1
--- /dev/null
+++ b/sys-apps/915resolution/915resolution-0.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Program for changing the resolution of an unavailable VBIOS mode on Intel 915 cards"
+HOMEPAGE="http://www.geocities.com/stomljen/"
+SRC_URI="http://www.geocities.com/stomljen/${PN}-${PV}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+RESTRICT="nomirror"
+S=${WORKDIR}/${PN}-${PV}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ install -m755 -D 915resolution ${D}/usr/sbin/915resolution \
+ || die "install failed"
+ dodoc README.txt
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf.d" 915resolution
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init.d" 915resolution
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Edit your the config file in /etc/conf.d as you need"
+ einfo "and add 915resolution to the default runlevel."
+ einfo ""
+}
+