summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2006-07-26 21:48:55 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2006-07-26 21:48:55 +0000
commitd37101c66ab85bcd59b1be8258eedc2e02606746 (patch)
treeb73b550c34c8bbeb79e121961e19a1065d97af3b /sys-apps
parentv4l2 cvs plugin (diff)
downloadzaheerm-d37101c66ab85bcd59b1be8258eedc2e02606746.tar.gz
zaheerm-d37101c66ab85bcd59b1be8258eedc2e02606746.tar.bz2
zaheerm-d37101c66ab85bcd59b1be8258eedc2e02606746.zip
915resolution and vbetool, needed for macbook
svn path=/; revision=10
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/915resolution/915resolution-0.5.2.ebuild40
-rw-r--r--sys-apps/915resolution/Manifest8
-rw-r--r--sys-apps/915resolution/files/digest-915resolution-0.5.23
-rw-r--r--sys-apps/vbetool/Manifest8
-rw-r--r--sys-apps/vbetool/files/digest-vbetool-0.63
-rw-r--r--sys-apps/vbetool/vbetool-0.6.ebuild34
6 files changed, 96 insertions, 0 deletions
diff --git a/sys-apps/915resolution/915resolution-0.5.2.ebuild b/sys-apps/915resolution/915resolution-0.5.2.ebuild
new file mode 100644
index 0000000..0d2e3d1
--- /dev/null
+++ b/sys-apps/915resolution/915resolution-0.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Program for changing the resolution of an unavailable VBIOS mode on Intel 915 cards"
+HOMEPAGE="http://www.geocities.com/stomljen/"
+SRC_URI="http://www.geocities.com/stomljen/${PN}-${PV}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+RESTRICT="nomirror"
+S=${WORKDIR}/${PN}-${PV}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ install -m755 -D 915resolution ${D}/usr/sbin/915resolution \
+ || die "install failed"
+ dodoc README.txt
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf.d" 915resolution
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init.d" 915resolution
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Edit your the config file in /etc/conf.d as you need"
+ einfo "and add 915resolution to the default runlevel."
+ einfo ""
+}
+
diff --git a/sys-apps/915resolution/Manifest b/sys-apps/915resolution/Manifest
new file mode 100644
index 0000000..9657a45
--- /dev/null
+++ b/sys-apps/915resolution/Manifest
@@ -0,0 +1,8 @@
+DIST 915resolution-0.5.2.tar.gz 21183 RMD160 722b352a83f41f0e9822ed4e096e8064f239dcc1 SHA1 9f26eb1b728ca0b2d28c948207b034a49b477089 SHA256 98827dd5adb5ffb5e415b2b28364033ffc173796555051ef52983ec5df77b6d4
+EBUILD 915resolution-0.5.2.ebuild 938 RMD160 c739612c1b786865b7af42890327ad45a6990a3e SHA1 5d3b35eda58539a8874d673091265bee503bb96f SHA256 1aa618ce35a53d352f169459acb8cb178ccfe34a4bd9afe4bcd59b86631c6f19
+MD5 311466032357d1aa16d7212d7e8f6c7b 915resolution-0.5.2.ebuild 938
+RMD160 c739612c1b786865b7af42890327ad45a6990a3e 915resolution-0.5.2.ebuild 938
+SHA256 1aa618ce35a53d352f169459acb8cb178ccfe34a4bd9afe4bcd59b86631c6f19 915resolution-0.5.2.ebuild 938
+MD5 4796a2ce0e9d7cc0f16a63fb5038e352 files/digest-915resolution-0.5.2 256
+RMD160 0dc3039740106b490b01db11cc33adea5bdc37fb files/digest-915resolution-0.5.2 256
+SHA256 a9b1e1c8d39680132cb47bfb19be139315dccd0a537fb97cc3a03eae79bc1499 files/digest-915resolution-0.5.2 256
diff --git a/sys-apps/915resolution/files/digest-915resolution-0.5.2 b/sys-apps/915resolution/files/digest-915resolution-0.5.2
new file mode 100644
index 0000000..a8810e3
--- /dev/null
+++ b/sys-apps/915resolution/files/digest-915resolution-0.5.2
@@ -0,0 +1,3 @@
+MD5 a3441e5662c5ff1e00dc97de4487e8f8 915resolution-0.5.2.tar.gz 21183
+RMD160 722b352a83f41f0e9822ed4e096e8064f239dcc1 915resolution-0.5.2.tar.gz 21183
+SHA256 98827dd5adb5ffb5e415b2b28364033ffc173796555051ef52983ec5df77b6d4 915resolution-0.5.2.tar.gz 21183
diff --git a/sys-apps/vbetool/Manifest b/sys-apps/vbetool/Manifest
new file mode 100644
index 0000000..aebacd0
--- /dev/null
+++ b/sys-apps/vbetool/Manifest
@@ -0,0 +1,8 @@
+DIST vbetool_0.6-1.tar.gz 170062 RMD160 d7cdbddeb84fc790d063988b75c8a48ae4041ee5 SHA1 1c4a4d2bb3ece3d5bed10efdfe370dc2b9e452b4 SHA256 000cdf1b699dd3dc840a1a6ea9b8649f42aaf6f618636ad820dc01b47231c824
+EBUILD vbetool-0.6.ebuild 1051 RMD160 a4fe32a7050aab2efe848c85ca781bab9d108477 SHA1 22842bac3d06089e7cd694df77a6524a90fcb6b1 SHA256 894dad3891a5eb475e4e26883bbb0f77db4d6c0781e828fe78fd3128df0bbb49
+MD5 8e25c08e4333021d45b8bfc025529381 vbetool-0.6.ebuild 1051
+RMD160 a4fe32a7050aab2efe848c85ca781bab9d108477 vbetool-0.6.ebuild 1051
+SHA256 894dad3891a5eb475e4e26883bbb0f77db4d6c0781e828fe78fd3128df0bbb49 vbetool-0.6.ebuild 1051
+MD5 b191973dd03c80b7244193ef6a95e668 files/digest-vbetool-0.6 241
+RMD160 e1f44e4f7a827c9df93b1c16d19a8b7a32f471da files/digest-vbetool-0.6 241
+SHA256 74e022939900d9ab6eb1d730455692fce55835a4423c14e30e1b4ae691d21306 files/digest-vbetool-0.6 241
diff --git a/sys-apps/vbetool/files/digest-vbetool-0.6 b/sys-apps/vbetool/files/digest-vbetool-0.6
new file mode 100644
index 0000000..e3943df
--- /dev/null
+++ b/sys-apps/vbetool/files/digest-vbetool-0.6
@@ -0,0 +1,3 @@
+MD5 53df26f99efb50abd9e8573ac7cc8e59 vbetool_0.6-1.tar.gz 170062
+RMD160 d7cdbddeb84fc790d063988b75c8a48ae4041ee5 vbetool_0.6-1.tar.gz 170062
+SHA256 000cdf1b699dd3dc840a1a6ea9b8649f42aaf6f618636ad820dc01b47231c824 vbetool_0.6-1.tar.gz 170062
diff --git a/sys-apps/vbetool/vbetool-0.6.ebuild b/sys-apps/vbetool/vbetool-0.6.ebuild
new file mode 100644
index 0000000..e0505a6
--- /dev/null
+++ b/sys-apps/vbetool/vbetool-0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/vbetool-0.5-r1.ebuild,v 1.1 2006/05/18 18:39:01 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Run real-mode video BIOS code to alter hardware state (i.e. reinitialize video card)"
+HOMEPAGE="http://www.srcf.ucam.org/~mjg59/vbetool/"
+#SRC_URI="${HOMEPAGE}${PN}_${PV}.orig.tar.gz"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P//-/_}-1.tar.gz"
+#SRC_URI="http://www.srcf.ucam.org/~mjg59/${PN}/${P//-/_}-1.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND="sys-apps/pciutils"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-0.5"
+
+#src_unpack() {
+# unpack ${A}
+# epatch ${FILESDIR}/${P}-pci-compile-fix.patch
+#}
+
+src_compile() {
+ # when on non-x86 machines, we need to use the x86 emulator
+ LIBS="-lpci" econf `use_with !x86 x86emu` || die "could not configure"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc LRMI
+}