aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-07-05 20:24:00 +0545
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-01-24 17:03:39 +0200
commit912453eb5cf191b95281cf48f230ee863d0a2739 (patch)
treee14ab94d2418da57f9cd794fd0ffb05770b7ef9a
parentGentoo: libiberty: install PIC version of libiberty.a (diff)
downloadbinutils-gdb-912453eb5cf191b95281cf48f230ee863d0a2739.tar.gz
binutils-gdb-912453eb5cf191b95281cf48f230ee863d0a2739.tar.bz2
binutils-gdb-912453eb5cf191b95281cf48f230ee863d0a2739.zip
Gentoo: opcodes: link against libbfd.la for rpath deps
The reason opcodes doesn't link against libbfd.la is to workaround a libtool bug where it uses installed -L paths ahead of DESTDIR paths. The downside is that the library itself lacks rpath tags to find the right version of libbfd.so. Since Gentoo has patched the libtool bug for a while, we don't need the workaround. Use the .la file so we get the rpath tags. URL: https://bugs.gentoo.org/563934 (cherry picked from commit 662586237b0b00ee881e79b56f6234ff36e8bfe6)
-rwxr-xr-xopcodes/configure2
-rw-r--r--opcodes/configure.ac2
2 files changed, 2 insertions, 2 deletions
diff --git a/opcodes/configure b/opcodes/configure
index dca94db9c3f..3ebd4c64acc 100755
--- a/opcodes/configure
+++ b/opcodes/configure
@@ -12787,7 +12787,7 @@ if test "$enable_shared" = "yes"; then
SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
;;
*)
- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
+ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
;;
esac
SHARED_DEPENDENCIES="../bfd/libbfd.la"
diff --git a/opcodes/configure.ac b/opcodes/configure.ac
index 07e95f0ee31..53b9ff2640d 100644
--- a/opcodes/configure.ac
+++ b/opcodes/configure.ac
@@ -188,7 +188,7 @@ changequote([,])dnl
SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
;;
*)
- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
+ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
;;
esac
SHARED_DEPENDENCIES="../bfd/libbfd.la"