aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Weimer <fweimer@redhat.com>2019-08-15 11:37:18 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-11-25 02:08:26 +0100
commit6cd6ee10ca85babd7601823b812d87f425017a56 (patch)
tree3e01c22705c41e12cd751787d28d4528afe8e455
parentAdd glibc.malloc.mxfast tunable (diff)
downloadglibc-6cd6ee10ca85babd7601823b812d87f425017a56.tar.gz
glibc-6cd6ee10ca85babd7601823b812d87f425017a56.tar.bz2
glibc-6cd6ee10ca85babd7601823b812d87f425017a56.zip
malloc: Various cleanups for malloc/tst-mxfast
(cherry picked from commit f9769a239784772453d595bc2f4bed8739810e06) (cherry picked from commit 1b96d1d90bd38fa95d2a78c48a3c08162add9472)
-rw-r--r--ChangeLog8
-rw-r--r--malloc/Makefile3
-rw-r--r--malloc/tst-mxfast.c14
3 files changed, 16 insertions, 9 deletions
diff --git a/ChangeLog b/ChangeLog
index cbdc566fa1..4a0af95f7a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+2019-08-15 Florian Weimer <fweimer@redhat.com>
+
+ * malloc/Makefile (tests): Only add tst-mxfast for
+ $(have-tunables).
+ * malloc/tst-mxfast.c: Fix copyright year.
+ (do_test): Fix GNU style issues. Use TEST_COMPARE instead of
+ assert for checks.
+
2019-08-09 DJ Delorie <dj@redhat.com>
* elf/dl-tunables.list: Add glibc.malloc.mxfast.
diff --git a/malloc/Makefile b/malloc/Makefile
index 26947feccf..b4409aa670 100644
--- a/malloc/Makefile
+++ b/malloc/Makefile
@@ -39,7 +39,6 @@ tests := mallocbug tst-malloc tst-valloc tst-calloc tst-obstack \
tst-malloc-too-large \
tst-malloc-stats-cancellation \
tst-tcfree1 tst-tcfree2 tst-tcfree3 \
- tst-mxfast \
tests-static := \
tst-interpose-static-nothread \
@@ -55,7 +54,7 @@ tests-internal += \
tst-dynarray-at-fail \
ifneq (no,$(have-tunables))
-tests += tst-malloc-usable-tunables
+tests += tst-malloc-usable-tunables tst-mxfast
tests-static += tst-malloc-usable-static-tunables
endif
diff --git a/malloc/tst-mxfast.c b/malloc/tst-mxfast.c
index 7a371d2f9d..7a7750bc71 100644
--- a/malloc/tst-mxfast.c
+++ b/malloc/tst-mxfast.c
@@ -1,5 +1,5 @@
/* Test that glibc.malloc.mxfast tunable works.
- Copyright (C) 2018, 2019 Free Software Foundation, Inc.
+ Copyright (C) 2019 Free Software Foundation, Inc.
This file is part of the GNU C Library.
The GNU C Library is free software; you can redistribute it and/or
@@ -21,14 +21,14 @@
the fast bins. */
#include <malloc.h>
-#include <assert.h>
+#include <support/check.h>
int
-do_test(void)
+do_test (void)
{
struct mallinfo m;
- char * volatile p1;
- char * volatile p2;
+ char *volatile p1;
+ char *volatile p2;
/* Arbitrary value; must be in default fastbin range. */
p1 = malloc (3);
@@ -36,10 +36,10 @@ do_test(void)
p2 = malloc (512);
free (p1);
- m = mallinfo();
+ m = mallinfo ();
/* This will fail if there are any blocks in the fastbins. */
- assert (m.smblks == 0);
+ TEST_COMPARE (m.smblks, 0);
/* To keep gcc happy. */
free (p2);