summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwiktor w brodlo <wiktor@brodlo.net>2011-06-21 15:28:05 +0000
committerwiktor w brodlo <wiktor@brodlo.net>2011-06-21 15:28:05 +0000
commit16aeb81f8411dbae89ba1dd4dd0b1afc5453bfcf (patch)
tree7463d2a361260772d88285c7163075c7bd3c950f
parentfcoe_edd.sh (see http://tinyurl.com/65ykyuv) (diff)
downloadanaconda-overlay-16aeb81f8411dbae89ba1dd4dd0b1afc5453bfcf.tar.gz
anaconda-overlay-16aeb81f8411dbae89ba1dd4dd0b1afc5453bfcf.tar.bz2
anaconda-overlay-16aeb81f8411dbae89ba1dd4dd0b1afc5453bfcf.zip
Removed sabayon-version, added gentoo-version
-rw-r--r--app-misc/anaconda-runtime/Manifest2
-rw-r--r--app-misc/anaconda-runtime/anaconda-runtime-0.1.ebuild2
-rw-r--r--app-misc/gentoo-version/Manifest1
-rw-r--r--app-misc/gentoo-version/gentoo-version-11.ebuild42
-rw-r--r--app-misc/sabayon-version/Manifest2
-rw-r--r--app-misc/sabayon-version/sabayon-version-5-r5.ebuild54
-rw-r--r--app-misc/sabayon-version/sabayon-version-6.ebuild54
7 files changed, 45 insertions, 112 deletions
diff --git a/app-misc/anaconda-runtime/Manifest b/app-misc/anaconda-runtime/Manifest
index 5d35b51..048963f 100644
--- a/app-misc/anaconda-runtime/Manifest
+++ b/app-misc/anaconda-runtime/Manifest
@@ -1 +1 @@
-EBUILD anaconda-runtime-0.1.ebuild 1094 RMD160 5ac15c90f8cee17ea27f149a091063974159c6e0 SHA1 64453ba5d57f290121f5d34a42cf8d04857e73d1 SHA256 4488c1e76c25edb9656c2406e3a9581c659a3243aa501fca3bdf3e68e56193aa
+EBUILD anaconda-runtime-0.1.ebuild 1090 RMD160 7f1e301539f0cda8ab81c7985724fd77d84ff82d SHA1 4f6408a827f78309b975325409760d0e7f63c4ec SHA256 b59d5b5e504617211385b00df7d489730fdbc23646152e9ddc8350cb5be89b38
diff --git a/app-misc/anaconda-runtime/anaconda-runtime-0.1.ebuild b/app-misc/anaconda-runtime/anaconda-runtime-0.1.ebuild
index 007340b..8b5a690 100644
--- a/app-misc/anaconda-runtime/anaconda-runtime-0.1.ebuild
+++ b/app-misc/anaconda-runtime/anaconda-runtime-0.1.ebuild
@@ -15,7 +15,7 @@ DEPEND=""
RDEPEND="app-admin/system-config-date
app-admin/system-config-users
>=app-misc/sabayonlive-tools-2.1.1
- >=app-misc/sabayon-version-5-r1
+ =app-misc/gentoo-version-11
app-text/xmlto
dev-libs/elfutils
dev-libs/libnl
diff --git a/app-misc/gentoo-version/Manifest b/app-misc/gentoo-version/Manifest
new file mode 100644
index 0000000..5df3b13
--- /dev/null
+++ b/app-misc/gentoo-version/Manifest
@@ -0,0 +1 @@
+EBUILD gentoo-version-11.ebuild 617 RMD160 a65213aaaf2b62fc72cd4f47f5285c64d20db3fb SHA1 36a83570ad98473fa91961aa8ed4a7c07069e89c SHA256 86cd210bb426ed2ed769b942ebeb859a0d4aad74ee51e4dfaaf3203496752b93
diff --git a/app-misc/gentoo-version/gentoo-version-11.ebuild b/app-misc/gentoo-version/gentoo-version-11.ebuild
new file mode 100644
index 0000000..e796c1d
--- /dev/null
+++ b/app-misc/gentoo-version/gentoo-version-11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2011 Gentoo Linux
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="Gentoo Linux LiveDVD release file"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE=""
+DEPEND=""
+
+src_unpack () {
+ # Set arch
+ if use amd64; then
+ ARCH=amd64;
+ fi
+ if use x86; then
+ ARCH=x86;
+ fi
+
+ # Set kernel
+ if use kernel_linux; then
+ KERN=Linux
+ fi
+
+ # Write file
+ echo "Gentoo ${KERN} ${ARCH} ${PV}" > livedvd-release
+
+}
+
+src_install () {
+ insinto /etc
+ doins livedvd-release
+ dosym /etc/livedvd-release /etc/system-release
+}
+
diff --git a/app-misc/sabayon-version/Manifest b/app-misc/sabayon-version/Manifest
deleted file mode 100644
index 4db75b2..0000000
--- a/app-misc/sabayon-version/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-EBUILD sabayon-version-5-r5.ebuild 1300 RMD160 f744ab8329e3b5b0e2e1848cf7dc3d7f88b54efd SHA1 d2ade1dfdcf13a3f026211591f44dad1f961d2b2 SHA256 30b1e95a156bc93af26bd60778fd673d178a9ff8070b93033c78b4f1793bc2a3
-EBUILD sabayon-version-6.ebuild 1300 RMD160 f744ab8329e3b5b0e2e1848cf7dc3d7f88b54efd SHA1 d2ade1dfdcf13a3f026211591f44dad1f961d2b2 SHA256 30b1e95a156bc93af26bd60778fd673d178a9ff8070b93033c78b4f1793bc2a3
diff --git a/app-misc/sabayon-version/sabayon-version-5-r5.ebuild b/app-misc/sabayon-version/sabayon-version-5-r5.ebuild
deleted file mode 100644
index 3c117e2..0000000
--- a/app-misc/sabayon-version/sabayon-version-5-r5.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2004-2011 Sabayon Linux
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=3
-
-DESCRIPTION="Sabayon System Release virtual package"
-HOMEPAGE="http://www.sabayon.org/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE=""
-DEPEND=""
-# Listing default packages for the current release
-RDEPEND="app-admin/eselect-python
- dev-lang/python:2.7
- sys-devel/gcc:4.5
- sys-devel/gcc-config"
-
-SABAYON_VER="${PV}"
-SABAYON_HEADER="Sabayon Linux"
-SABAYON_RELEASE="sabayon-release"
-
-src_unpack () {
- if use x86; then
- echo "${SABAYON_HEADER} x86 ${SABAYON_VER}" > "${SABAYON_RELEASE}"
- else
- echo "${SABAYON_HEADER} amd64 ${SABAYON_VER}" > "${SABAYON_RELEASE}"
- fi
-}
-
-src_install () {
- insinto /etc
- doins sabayon-release
- dosym /etc/sabayon-release /etc/system-release
-}
-
-pkg_postinst() {
- # Setup Python 2.7
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 --ignore 3.3 --ignore 3.4
-
- # Setup GCC 4.5 (it's also in packages.db.post_upgrade.sh
- c_profile=$(gcc-config -l | grep "\-4.5" | cut -d"[" -f 2 | cut -d"]" -f 1)
- [[ "${?}" != "0" ]] && ewarn "gcc-config script error" && exit 1
- if [[ ${c_profile} =~ ^[0-9]+$ ]]; then
- gcc-config ${c_profile}
- env-update
- else
- ewarn "gcc-config unable to set new profile:" ${c_profile}
- fi
-}
diff --git a/app-misc/sabayon-version/sabayon-version-6.ebuild b/app-misc/sabayon-version/sabayon-version-6.ebuild
deleted file mode 100644
index 3c117e2..0000000
--- a/app-misc/sabayon-version/sabayon-version-6.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2004-2011 Sabayon Linux
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=3
-
-DESCRIPTION="Sabayon System Release virtual package"
-HOMEPAGE="http://www.sabayon.org/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE=""
-DEPEND=""
-# Listing default packages for the current release
-RDEPEND="app-admin/eselect-python
- dev-lang/python:2.7
- sys-devel/gcc:4.5
- sys-devel/gcc-config"
-
-SABAYON_VER="${PV}"
-SABAYON_HEADER="Sabayon Linux"
-SABAYON_RELEASE="sabayon-release"
-
-src_unpack () {
- if use x86; then
- echo "${SABAYON_HEADER} x86 ${SABAYON_VER}" > "${SABAYON_RELEASE}"
- else
- echo "${SABAYON_HEADER} amd64 ${SABAYON_VER}" > "${SABAYON_RELEASE}"
- fi
-}
-
-src_install () {
- insinto /etc
- doins sabayon-release
- dosym /etc/sabayon-release /etc/system-release
-}
-
-pkg_postinst() {
- # Setup Python 2.7
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 --ignore 3.3 --ignore 3.4
-
- # Setup GCC 4.5 (it's also in packages.db.post_upgrade.sh
- c_profile=$(gcc-config -l | grep "\-4.5" | cut -d"[" -f 2 | cut -d"]" -f 1)
- [[ "${?}" != "0" ]] && ewarn "gcc-config script error" && exit 1
- if [[ ${c_profile} =~ ^[0-9]+$ ]]; then
- gcc-config ${c_profile}
- env-update
- else
- ewarn "gcc-config unable to set new profile:" ${c_profile}
- fi
-}