summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwiktor w brodlo <wiktor@brodlo.net>2011-06-09 21:10:07 +0000
committerwiktor w brodlo <wiktor@brodlo.net>2011-06-09 21:10:07 +0000
commitefeb38a7c1235e045e0421a207e9ef19d61bd0c2 (patch)
tree623edb1f189c27f24d2396d25699450b1a3c55fb /app-admin
parentDeps and anaconda, imported from Sabayon (diff)
downloadanaconda-overlay-efeb38a7c1235e045e0421a207e9ef19d61bd0c2.tar.gz
anaconda-overlay-efeb38a7c1235e045e0421a207e9ef19d61bd0c2.tar.bz2
anaconda-overlay-efeb38a7c1235e045e0421a207e9ef19d61bd0c2.zip
Fixed categories
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/anaconda/Manifest8
-rw-r--r--app-admin/anaconda/anaconda-0.9.9.53.ebuild216
-rw-r--r--app-admin/anaconda/anaconda-9999.ebuild217
-rw-r--r--app-admin/anaconda/files/compat.py18
-rw-r--r--app-admin/anaconda/files/liveinst2
-rw-r--r--app-admin/anaconda/files/make_liveinst_update_package.sh24
-rw-r--r--app-admin/firstboot/Manifest2
-rw-r--r--app-admin/firstboot/firstboot-1.110-r1.ebuild32
-rw-r--r--app-admin/system-config-date/Manifest2
-rw-r--r--app-admin/system-config-date/system-config-date-1.9.57-r1.ebuild50
-rw-r--r--app-admin/system-config-keyboard/Manifest2
-rw-r--r--app-admin/system-config-keyboard/system-config-keyboard-1.3.1.ebuild23
-rw-r--r--app-admin/system-config-users/Manifest3
-rw-r--r--app-admin/system-config-users/files/system-config-users-kill-rpm.patch35
-rw-r--r--app-admin/system-config-users/system-config-users-1.2.96-r2.ebuild52
15 files changed, 686 insertions, 0 deletions
diff --git a/app-admin/anaconda/Manifest b/app-admin/anaconda/Manifest
new file mode 100644
index 0000000..f6e3318
--- /dev/null
+++ b/app-admin/anaconda/Manifest
@@ -0,0 +1,8 @@
+AUX compat.py 461 RMD160 ae776a51f27564321845126c39874eab953a41cd SHA1 229eea09e82b4e93150ece0f0621ac4581ccb00b SHA256 d3b3efe9b9fd946c917a6faccca715c4056748b9c861080fe6f6d7cfbaf87f50
+AUX liveinst 40 RMD160 39595adfb6c90dcf5b30d1ebdd7f0fac224d6d16 SHA1 4ec5b3c634341ca1e856fbffe69a61236f8335af SHA256 32721c6398f6b7e77e45ed5cbbe32c15b9b2ae424311ae4fe77d95c2b17a8af3
+AUX make_liveinst_update_package.sh 653 RMD160 0c7e88651d03d25210ca36500e28e0bc2caa7172 SHA1 abf190bf40d5d8b0ddd0ff99a69c5096b47c949b SHA256 cfec6af92438e670dbc3341519e65a6847640003708a07e6d78aca187d307d2c
+DIST anaconda-0.9.9.53.tar.bz2 13342352 RMD160 89839bb189a2c439aba937e85bc658350035ba1a SHA1 93a2edc5cbf58f7c89d15da59babd576cc326363 SHA256 27c473aa5ed1e60cfbbf65104236ed549e937e095dd2f50f172d6b06366f2686
+DIST audit-1.7.9.tar.gz 1245155 RMD160 248ca395c6d58dccf8437750e6cf5a7040a28c9f SHA1 aa7de4546f4774338946987fe1a8231222475e64 SHA256 95ce67d9aee4339a5aa11214f21dfa5f37c5820e2511c7bddf998d26b1aaefc9
+DIST libselinux-2.0.85.tar.gz 175396 RMD160 ce27fc9c5baf23d9f1c2eeda24357abc4d619d48 SHA1 b2e29934f3cde0a2fb86fe29c8cc1abac8c7e9ca SHA256 54db845fbaa2b3183798e6754b11e4178802f9eae47569b391d87a45b8a69c3c
+EBUILD anaconda-0.9.9.53.ebuild 6564 RMD160 9a631970ef7f99761c26ef61b3046aa16ccc54b2 SHA1 44e02d5fdc1ef35c3feb67fa735b7a34a8e342cd SHA256 3ab7a8ab17dfb6efb8df46412248e85b1824185c1ffe2893f639aa41c7d9b5e7
+EBUILD anaconda-9999.ebuild 6579 RMD160 27b71cca78530c162aeb16fc6b4da99f06c30f2a SHA1 f0cdfe257b33e386f79c8e10dda5c8f336638d11 SHA256 6cb901e23dd10a46c6823d29b89e95629d59c6894c4511b48c9a9c377f812047
diff --git a/app-admin/anaconda/anaconda-0.9.9.53.ebuild b/app-admin/anaconda/anaconda-0.9.9.53.ebuild
new file mode 100644
index 0000000..f96b8d0
--- /dev/null
+++ b/app-admin/anaconda/anaconda-0.9.9.53.ebuild
@@ -0,0 +1,216 @@
+# Copyright 2004-2010 Sabayon
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_COMMIT="master"
+ EGIT_REPO_URI="git://sabayon.org/projects/anaconda.git"
+ MY_ECLASS="git"
+fi
+inherit flag-o-matic base python libtool autotools eutils ${MY_ECLASS}
+
+AUDIT_VER="1.7.9"
+AUDIT_SRC_URI="http://people.redhat.com/sgrubb/audit/audit-${AUDIT_VER}.tar.gz"
+
+SEPOL_VER="2.0"
+LSELINUX_VER="2.0.85"
+LSELINUX_SRC_URI="http://userspace.selinuxproject.org/releases/current/devel/libselinux-${LSELINUX_VER}.tar.gz"
+
+DESCRIPTION="Sabayon Redhat Anaconda Installer Port"
+HOMEPAGE="http://gitweb.sabayon.org/?p=anaconda.git;a=summary"
+if [ "${PV}" = "9999" ]; then
+ SRC_URI="${AUDIT_SRC_URI} ${LSELINUX_SRC_URI}"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sabayon/${CATEGORY}/${PN}-${PVR}.tar.bz2 ${AUDIT_SRC_URI} ${LSELINUX_SRC_URI}"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${WORKDIR}"/${PN}-${PVR}
+AUDIT_S="${WORKDIR}/audit-${AUDIT_VER}"
+LSELINUX_S="${WORKDIR}/libselinux-${LSELINUX_VER}"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+IUSE="+ipv6 +nfs ldap"
+
+AUDIT_DEPEND="dev-lang/swig"
+AUDIT_RDEPEND="ldap? ( net-nds/openldap )"
+LSELINUX_DEPEND="=sys-libs/libsepol-${SEPOL_VER}* dev-lang/swig"
+LSELINUX_RDEPEND="=sys-libs/libsepol-${SEPOL_VER}*"
+LSELINUX_CONFLICT="!sys-libs/libselinux" # due to pythonX.Y/site-packages+/usr/sbin not being handled
+COMMON_DEPEND="app-admin/system-config-keyboard
+ >=app-arch/libarchive-2.8
+ app-cdr/isomd5sum
+ dev-libs/newt
+ nfs? ( net-fs/nfs-utils )
+ sys-fs/lvm2
+ sys-block/open-iscsi"
+DEPEND="${COMMON_DEPEND} ${AUDIT_DEPEND} ${LSELINUX_DEPEND} sys-apps/sed"
+RDEPEND="${COMMON_DEPEND} ${AUDIT_RDEPEND}
+ ${LSELINUX_RDEPEND} ${LSELINUX_CONFLICT}
+ >=app-misc/anaconda-runtime-1.1"
+
+# FIXME:
+# for anaconda-gtk we would require also
+# dev-python/pygtk
+# x11-libs/pango
+
+src_unpack() {
+ if [ "${PV}" = "9999" ]; then
+ git_src_unpack
+ base_src_unpack
+ else
+ base_src_unpack
+ fi
+}
+
+src_prepare() {
+
+ # Setup CFLAGS, LDFLAGS
+ append-cflags "-I${D}/usr/include/anaconda-runtime"
+ append-ldflags "-L${D}/usr/$(get_libdir)/anaconda-runtime"
+
+ # Setup anaconda
+ cd "${S}"
+ ./autogen.sh || die "cannot run autogen"
+
+ ##
+ ## Setup libaudit
+ ##
+ cd "${AUDIT_S}"
+ # Do not build GUI tools
+ sed -i \
+ -e '/AC_CONFIG_SUBDIRS.*system-config-audit/d' \
+ "${AUDIT_S}"/configure.ac || die "cannot sed libaudit configure.ac"
+ sed -i \
+ -e 's,system-config-audit,,g' \
+ -e '/^SUBDIRS/s,\\$,,g' \
+ "${AUDIT_S}"/Makefile.am || die "cannot sed libaudit Makefile.am"
+ rm -rf "${AUDIT_S}"/system-config-audit
+
+ if ! use ldap; then
+ sed -i \
+ -e '/^AC_OUTPUT/s,audisp/plugins/zos-remote/Makefile,,g' \
+ "${AUDIT_S}"/configure.ac || die "cannot sed libaudit configure.ac (ldap)"
+ sed -i \
+ -e '/^SUBDIRS/s,zos-remote,,g' \
+ "${AUDIT_S}"/audisp/plugins/Makefile.am || die "cannot sed libaudit Makefile.am (ldap)"
+ fi
+ eautoreconf
+
+}
+
+copy_audit_data_over() {
+ dodir "/usr/$(get_libdir)/anaconda-runtime"
+ cp -Ra "${AUDIT_S}/fakeroot/usr/$(get_libdir)/anaconda-runtime/"* \
+ "${D}/usr/$(get_libdir)/anaconda-runtime" || die "cannot cp audit data"
+ dodir "/usr/include/anaconda-runtime"
+ cp -Ra "${AUDIT_S}/fakeroot/usr/include/anaconda-runtime/"* \
+ "${D}/usr/include/anaconda-runtime" || die "cannot cp audit include data"
+}
+
+src_configure() {
+ # configure audit
+ cd "${AUDIT_S}"
+ einfo "configuring audit"
+ econf --sbindir=/sbin --libdir=/usr/$(get_libdir)/anaconda-runtime \
+ --includedir=/usr/include/anaconda-runtime \
+ --without-prelude || die
+
+ # compiling audit here, anaconda configure needs libaudit
+ einfo "compiling audit"
+ cd "${AUDIT_S}" || die "cannot cd into ${AUDIT_S}"
+ base_src_compile
+
+ # installing audit
+ einfo "installing audit libs into ${AUDIT_S}/fakeroot temporarily"
+ cd "${AUDIT_S}" || die "cannot cd into ${AUDIT_S}"
+ ( rm -rf fakeroot && mkdir fakeroot ) || die "cannot mkdir"
+ emake DESTDIR="${AUDIT_S}/fakeroot" install || die "cannot install libaudit"
+ copy_audit_data_over # for proper linking
+
+ # configure anaconda
+ cd "${S}"
+ einfo "configuring anaconda"
+ econf \
+ $(use_enable ipv6) $(use_enable selinux) \
+ $(use_enable nfs) || die "configure failed"
+}
+
+src_compile() {
+
+ cd "${S}"
+ base_src_compile
+
+ # compiling libselinux
+ einfo "compiling libselinux"
+ cd "${LSELINUX_S}" || die "cannot cd into ${LSELINUX_S}"
+ LD_RUN_PATH="/usr/$(get_libdir)/anaconda-runtime" \
+ emake \
+ LDFLAGS="-fPIC ${LDFLAGS}" \
+ PYLIBVER="python$(python_get_version)" \
+ PYTHONLIBDIR="${D}/usr/$(get_libdir)/python$(python_get_version)" \
+ SHLIBDIR="${D}/usr/$(get_libdir)/anaconda-runtime" \
+ INCLUDEDIR="${D}/usr/include/anaconda-runtime" \
+ all || die
+ LD_RUN_PATH="/usr/$(get_libdir)/anaconda-runtime" \
+ emake \
+ LDFLAGS="-fPIC ${LDFLAGS}" \
+ PYLIBVER="python$(python_get_version)" \
+ PYTHONLIBDIR="${D}/usr/$(get_libdir)/python$(python_get_version)" \
+ SHLIBDIR="${D}/usr/$(get_libdir)/anaconda-runtime" \
+ INCLUDEDIR="${D}/usr/include/anaconda-runtime" \
+ pywrap || die
+
+ # add compatibility aliases to swig wrapper
+ cat "${FILESDIR}/compat.py" >> "${LSELINUX_S}/src/selinux.py" || die
+
+}
+
+src_install() {
+
+ # installing libselinux
+ cd "${LSELINUX_S}"
+ python_need_rebuild
+ LD_RUN_PATH="/usr/$(get_libdir)/anaconda-runtime" \
+ emake DESTDIR="${D}" \
+ PYLIBVER="python$(python_get_version)" \
+ PYTHONLIBDIR="${D}/usr/$(get_libdir)/python$(python_get_version)" \
+ LIBDIR="${D}/usr/$(get_libdir)/anaconda-runtime" \
+ SHLIBDIR="${D}/usr/$(get_libdir)/anaconda-runtime" \
+ INCLUDEDIR="${D}/usr/include/anaconda-runtime" \
+ install install-pywrap || die
+
+ # fix libselinux.so link
+ dosym libselinux.so.1 /usr/$(get_libdir)/anaconda-runtime/libselinux.so
+ # LD_RUN_PATH works with ld >=2.20, so /etc/env.d/99anaconda for now
+ # will be dropped in future
+ echo "LDPATH=\"/usr/$(get_libdir)/anaconda-runtime\"" > 99anaconda
+ doenvd 99anaconda
+
+ cd "${S}"
+ copy_audit_data_over # ${D} is cleared
+ base_src_install
+
+ # install liveinst for user
+ dodir /usr/bin
+ exeinto /usr/bin
+ doexe "${FILESDIR}"/liveinst
+ dosym /usr/bin/liveinst /usr/bin/installer
+
+ # drop .la files for God sake
+ find "${D}" -name "*.la" | xargs rm
+
+ # Cleanup .pyc .pyo
+ find "${D}" -name "*.py[co]" -type f -delete
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/py${PN}
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/py${PN}
+}
diff --git a/app-admin/anaconda/anaconda-9999.ebuild b/app-admin/anaconda/anaconda-9999.ebuild
new file mode 100644
index 0000000..0b7967e
--- /dev/null
+++ b/app-admin/anaconda/anaconda-9999.ebuild
@@ -0,0 +1,217 @@
+# Copyright 2004-2010 Sabayon
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_COMMIT="master"
+ EGIT_REPO_URI="git://sabayon.org/projects/anaconda.git"
+ MY_ECLASS="git"
+fi
+inherit flag-o-matic base python libtool autotools eutils ${MY_ECLASS}
+
+AUDIT_VER="1.7.9"
+AUDIT_SRC_URI="http://people.redhat.com/sgrubb/audit/audit-${AUDIT_VER}.tar.gz"
+
+SEPOL_VER="2.0"
+LSELINUX_VER="2.0.85"
+LSELINUX_SRC_URI="http://userspace.selinuxproject.org/releases/current/devel/libselinux-${LSELINUX_VER}.tar.gz"
+
+DESCRIPTION="Sabayon Redhat Anaconda Installer Port"
+HOMEPAGE="http://gitweb.sabayon.org/?p=anaconda.git;a=summary"
+if [ "${PV}" = "9999" ]; then
+ SRC_URI="${AUDIT_SRC_URI} ${LSELINUX_SRC_URI}"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sabayon/${CATEGORY}/${PN}-${PVR}.tar.bz2 ${AUDIT_SRC_URI} ${LSELINUX_SRC_URI}"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${WORKDIR}"/${PN}-${PVR}
+AUDIT_S="${WORKDIR}/audit-${AUDIT_VER}"
+LSELINUX_S="${WORKDIR}/libselinux-${LSELINUX_VER}"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+IUSE="+ipv6 +nfs ldap"
+
+AUDIT_DEPEND="dev-lang/swig"
+AUDIT_RDEPEND="ldap? ( net-nds/openldap )"
+LSELINUX_DEPEND="=sys-libs/libsepol-${SEPOL_VER}* dev-lang/swig"
+LSELINUX_RDEPEND="=sys-libs/libsepol-${SEPOL_VER}*"
+LSELINUX_CONFLICT="!sys-libs/libselinux" # due to pythonX.Y/site-packages+/usr/sbin not being handled
+COMMON_DEPEND="app-admin/system-config-keyboard
+ >=app-arch/libarchive-2.8
+ app-cdr/isomd5sum
+ dev-libs/newt
+ nfs? ( net-fs/nfs-utils )
+ sys-fs/lvm2
+ =sys-block/open-iscsi-2.0.870.3-r1"
+DEPEND="${COMMON_DEPEND} ${AUDIT_DEPEND} ${LSELINUX_DEPEND} sys-apps/sed"
+RDEPEND="${COMMON_DEPEND} ${AUDIT_RDEPEND}
+ ${LSELINUX_RDEPEND} ${LSELINUX_CONFLICT}
+ >=app-misc/anaconda-runtime-1.1"
+
+# FIXME:
+# for anaconda-gtk we would require also
+# dev-python/pygtk
+# x11-libs/pango
+
+src_unpack() {
+ if [ "${PV}" = "9999" ]; then
+ git_src_unpack
+ base_src_unpack
+ else
+ base_src_unpack
+ fi
+}
+
+src_prepare() {
+
+ # Setup CFLAGS, LDFLAGS
+ append-cflags "-I${D}/usr/include/anaconda-runtime"
+ append-ldflags "-L${D}/usr/$(get_libdir)/anaconda-runtime"
+
+ # Setup anaconda
+ cd "${S}"
+ ./autogen.sh || die "cannot run autogen"
+
+ ##
+ ## Setup libaudit
+ ##
+ cd "${AUDIT_S}"
+ # Do not build GUI tools
+ sed -i \
+ -e '/AC_CONFIG_SUBDIRS.*system-config-audit/d' \
+ "${AUDIT_S}"/configure.ac || die "cannot sed libaudit configure.ac"
+ sed -i \
+ -e 's,system-config-audit,,g' \
+ -e '/^SUBDIRS/s,\\$,,g' \
+ "${AUDIT_S}"/Makefile.am || die "cannot sed libaudit Makefile.am"
+ rm -rf "${AUDIT_S}"/system-config-audit
+
+ if ! use ldap; then
+ sed -i \
+ -e '/^AC_OUTPUT/s,audisp/plugins/zos-remote/Makefile,,g' \
+ "${AUDIT_S}"/configure.ac || die "cannot sed libaudit configure.ac (ldap)"
+ sed -i \
+ -e '/^SUBDIRS/s,zos-remote,,g' \
+ "${AUDIT_S}"/audisp/plugins/Makefile.am || die "cannot sed libaudit Makefile.am (ldap)"
+ fi
+ eautoreconf
+
+}
+
+copy_audit_data_over() {
+ dodir "/usr/$(get_libdir)/anaconda-runtime"
+ cp -Ra "${AUDIT_S}/fakeroot/usr/$(get_libdir)/anaconda-runtime/"* \
+ "${D}/usr/$(get_libdir)/anaconda-runtime" || die "cannot cp audit data"
+ dodir "/usr/include/anaconda-runtime"
+ cp -Ra "${AUDIT_S}/fakeroot/usr/include/anaconda-runtime/"* \
+ "${D}/usr/include/anaconda-runtime" || die "cannot cp audit include data"
+}
+
+src_configure() {
+ # configure audit
+ cd "${AUDIT_S}"
+ einfo "configuring audit"
+ econf --sbindir=/sbin --libdir=/usr/$(get_libdir)/anaconda-runtime \
+ --includedir=/usr/include/anaconda-runtime \
+ --without-prelude || die
+
+ # compiling audit here, anaconda configure needs libaudit
+ einfo "compiling audit"
+ cd "${AUDIT_S}" || die "cannot cd into ${AUDIT_S}"
+ base_src_compile
+
+ # installing audit
+ einfo "installing audit libs into ${AUDIT_S}/fakeroot temporarily"
+ cd "${AUDIT_S}" || die "cannot cd into ${AUDIT_S}"
+ ( rm -rf fakeroot && mkdir fakeroot ) || die "cannot mkdir"
+ emake DESTDIR="${AUDIT_S}/fakeroot" install || die "cannot install libaudit"
+ copy_audit_data_over # for proper linking
+
+ # configure anaconda
+ cd "${S}"
+ einfo "configuring anaconda"
+ econf \
+ $(use_enable ipv6) $(use_enable selinux) \
+ $(use_enable nfs) || die "configure failed"
+}
+
+src_compile() {
+
+ cd "${S}"
+ base_src_compile
+
+ # compiling libselinux
+ einfo "compiling libselinux"
+ cd "${LSELINUX_S}" || die "cannot cd into ${LSELINUX_S}"
+ LD_RUN_PATH="/usr/$(get_libdir)/anaconda-runtime" \
+ emake \
+ LDFLAGS="-fPIC ${LDFLAGS}" \
+ PYLIBVER="python$(python_get_version)" \
+ PYTHONLIBDIR="${D}/usr/$(get_libdir)/python$(python_get_version)" \
+ SHLIBDIR="${D}/usr/$(get_libdir)/anaconda-runtime" \
+ INCLUDEDIR="${D}/usr/include/anaconda-runtime" \
+ all || die
+ LD_RUN_PATH="/usr/$(get_libdir)/anaconda-runtime" \
+ emake \
+ LDFLAGS="-fPIC ${LDFLAGS}" \
+ PYLIBVER="python$(python_get_version)" \
+ PYTHONLIBDIR="${D}/usr/$(get_libdir)/python$(python_get_version)" \
+ SHLIBDIR="${D}/usr/$(get_libdir)/anaconda-runtime" \
+ INCLUDEDIR="${D}/usr/include/anaconda-runtime" \
+ pywrap || die
+
+ # add compatibility aliases to swig wrapper
+ cat "${FILESDIR}/compat.py" >> "${LSELINUX_S}/src/selinux.py" || die
+
+}
+
+src_install() {
+
+ # installing libselinux
+ cd "${LSELINUX_S}"
+ python_need_rebuild
+ LD_RUN_PATH="/usr/$(get_libdir)/anaconda-runtime" \
+ emake DESTDIR="${D}" \
+ PYLIBVER="python$(python_get_version)" \
+ PYTHONLIBDIR="${D}/usr/$(get_libdir)/python$(python_get_version)" \
+ LIBDIR="${D}/usr/$(get_libdir)/anaconda-runtime" \
+ SHLIBDIR="${D}/usr/$(get_libdir)/anaconda-runtime" \
+ INCLUDEDIR="${D}/usr/include/anaconda-runtime" \
+ install install-pywrap || die
+
+ # fix libselinux.so link
+ dosym libselinux.so.1 /usr/$(get_libdir)/anaconda-runtime/libselinux.so
+ # LD_RUN_PATH works with ld >=2.20, so /etc/env.d/99anaconda for now
+ # will be dropped in future
+ echo "LDPATH=\"/usr/$(get_libdir)/anaconda-runtime\"" > 99anaconda
+ doenvd 99anaconda
+
+ cd "${S}"
+ copy_audit_data_over # ${D} is cleared
+ base_src_install
+
+ # install liveinst for user
+ dodir /usr/bin
+ exeinto /usr/bin
+ doexe "${FILESDIR}"/liveinst
+ dosym /usr/bin/liveinst /usr/bin/installer
+
+ # drop .la files for God sake
+ find "${D}" -name "*.la" | xargs rm
+
+ # Cleanup .pyc .pyo
+ find "${D}" -name "*.py[co]" -type f -delete
+
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/py${PN}
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/py${PN}
+}
diff --git a/app-admin/anaconda/files/compat.py b/app-admin/anaconda/files/compat.py
new file mode 100644
index 0000000..b0bf65b
--- /dev/null
+++ b/app-admin/anaconda/files/compat.py
@@ -0,0 +1,18 @@
+# compatability aliases for python-selinux
+try:
+ import selinux_aux
+
+ enabled = selinux_aux.enabled
+
+ get_lsid = selinux_aux.get_lsid
+ get_sid = selinux_aux.get_sid
+ set_sid = selinux_aux.set_sid
+ secure_rename = selinux_aux.secure_rename
+ secure_copy = selinux_aux.secure_copy
+ secure_mkdir = selinux_aux.secure_mkdir
+ secure_symlink = selinux_aux.secure_symlink
+ setexec = selinux_aux.setexec
+ getcontext = selinux_aux.getcontext
+
+except:
+ pass
diff --git a/app-admin/anaconda/files/liveinst b/app-admin/anaconda/files/liveinst
new file mode 100644
index 0000000..986da86
--- /dev/null
+++ b/app-admin/anaconda/files/liveinst
@@ -0,0 +1,2 @@
+#!/bin/sh
+sudo -E /usr/sbin/liveinst $@
diff --git a/app-admin/anaconda/files/make_liveinst_update_package.sh b/app-admin/anaconda/files/make_liveinst_update_package.sh
new file mode 100644
index 0000000..466408c
--- /dev/null
+++ b/app-admin/anaconda/files/make_liveinst_update_package.sh
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+if [ -z "${1}" ]; then
+ echo "syntax ${0} <ebuild>"
+ exit 1
+fi
+eb="${1}"
+eb_name=$(basename "${eb}")
+tbz2_name="${eb_name/.ebuild/.tbz2}"
+tar_file="py${eb_name/.ebuild}.tar.bz2"
+current_dir="${PWD}"
+
+ebuild "${eb}" clean package || exit 1
+tmp_dir="$(mktemp -d)"
+
+cp /usr/portage/packages/app-admin/"${tbz2_name}" "${tmp_dir}" || exit 1
+cd "${tmp_dir}" || exit 1
+tar xvf "${tbz2_name}" || exit 1
+
+( cd usr/lib*/python*/site-packages && tar cjf \
+ "${current_dir}/${tar_file}" pyanaconda ) || exit 1
+( cd "${current_dir}" && md5sum "${tar_file}" > "${tar_file}.md5" ) || exit 1
+
+echo "created ${tar_file} and ${tar_file}.md5 in this directory"
diff --git a/app-admin/firstboot/Manifest b/app-admin/firstboot/Manifest
new file mode 100644
index 0000000..7e464ce
--- /dev/null
+++ b/app-admin/firstboot/Manifest
@@ -0,0 +1,2 @@
+DIST firstboot-1.110-1.fc13.src.rpm 171365 RMD160 2c18e2cfc384e1776f0112d2873828a720c5a9ac SHA1 1a78f4b68beba24fb288c32efe97603fb444b7a6 SHA256 f463bea5eb96706a09a5e87dd70a4fea0c8e579f756cb8316c96d8db41304f9f
+EBUILD firstboot-1.110-r1.ebuild 906 RMD160 d43aa8dfa191ebf79e9f850cac95c37268d3ed31 SHA1 5ea5a19c55b3ec320fcb492efdb812b6102202fe SHA256 c6ae1b948e947e3bd94f1b10830f849ae12ec8fe54e389dc7ba25f0fbfeb31d2
diff --git a/app-admin/firstboot/firstboot-1.110-r1.ebuild b/app-admin/firstboot/firstboot-1.110-r1.ebuild
new file mode 100644
index 0000000..052e7ca
--- /dev/null
+++ b/app-admin/firstboot/firstboot-1.110-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/firstboot/firstboot-1.4.19.ebuild,v 1.3 2007/10/15 09:35:28 dberkholz Exp $
+
+EAPI=3
+inherit python distutils rpm
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="Initial system configuration utility"
+HOMEPAGE="http://fedoraproject.org/wiki/FirstBoot"
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}-${RPMREV}.fc13.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="gtk"
+RDEPEND="
+ gtk? ( =dev-python/pygtk-2* )
+ dev-python/rhpl
+ app-admin/system-config-users
+ app-admin/system-config-date
+ sys-libs/libuser
+ dev-python/python-ethtool"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+PDEPEND="app-admin/system-config-keyboard"
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-admin/system-config-date/Manifest b/app-admin/system-config-date/Manifest
new file mode 100644
index 0000000..f52047b
--- /dev/null
+++ b/app-admin/system-config-date/Manifest
@@ -0,0 +1,2 @@
+DIST system-config-date-1.9.57.tar.bz2 807711 RMD160 68cf77bf671f6716268f7ab1dc2f1a4393a7dc5a SHA1 5fa9bb48d81a428fe3650b2b592f3c0a7a434bea SHA256 d9228773fb5b051cf6b812a7092123606e851ae14b65d6b1424d09101daaa922
+EBUILD system-config-date-1.9.57-r1.ebuild 1334 RMD160 f8ed44204b4b9465771ce271ba5440617559d072 SHA1 c784aace52118278358ecfab1aa8da13d602105d SHA256 1267ae457b5a93b4f03bffcd1021ed3a248130c3a4f0cffcda82db520e7ed9e7
diff --git a/app-admin/system-config-date/system-config-date-1.9.57-r1.ebuild b/app-admin/system-config-date/system-config-date-1.9.57-r1.ebuild
new file mode 100644
index 0000000..52e4012
--- /dev/null
+++ b/app-admin/system-config-date/system-config-date-1.9.57-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2004-2010 Sabayon
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI="2"
+inherit python base
+
+DESCRIPTION="The system-config-date tool lets you set the date and time of your machine."
+HOMEPAGE="http://fedoraproject.org/wiki/SystemConfig/date"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-1"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="gtk"
+
+# FIXME: would also require a dependency against anaconda
+DEPEND="app-text/docbook-xml-dtd
+ app-text/docbook-sgml-dtd
+ app-text/gnome-doc-utils
+ app-text/rarian
+ dev-libs/newt
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-devel/gettext"
+
+# also net-misc/ntp would be a soft-dependency
+# but code is redhat-centric, so we won't really
+# let user use this crap
+# net-misc/ntp
+RDEPEND="dev-libs/newt
+ dev-python/python-slip
+ dev-python/rhpl
+ gtk? ( dev-python/pygtk:2
+ dev-python/libgnomecanvas-python
+ x11-themes/hicolor-icon-theme )"
+
+src_install() {
+ base_src_install
+
+ # removing .desktop file, not advertising this, it is
+ # only needed by app-admin/anaconda
+ rm -rf "${D}/usr/share/"{man,applications}
+ rm -rf "${D}/etc/"{pam.d,security}
+ rm -rf "${D}/usr/bin"
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-admin/system-config-keyboard/Manifest b/app-admin/system-config-keyboard/Manifest
new file mode 100644
index 0000000..ada060b
--- /dev/null
+++ b/app-admin/system-config-keyboard/Manifest
@@ -0,0 +1,2 @@
+DIST system-config-keyboard-1.3.1.tar.gz 118192 RMD160 f90533fbc7286341aa0d2aa1eeb2aa2e1bcdfbbd SHA1 daf90413f8ea80cb1ac9815a34031779933038e1 SHA256 ba446a871fa4db096930825cbc656541cac5e0302e955e3656289532967159ed
+EBUILD system-config-keyboard-1.3.1.ebuild 553 RMD160 8f306f78e6b2d186344f319d34ad2048a3756e9f SHA1 6287c3d042cfb746f5120d84c2ce0ef6483fbed0 SHA256 20c56debc454cff77e6c4e62e4991b58ce443c3bb37ed12cce41507c7738aee3
diff --git a/app-admin/system-config-keyboard/system-config-keyboard-1.3.1.ebuild b/app-admin/system-config-keyboard/system-config-keyboard-1.3.1.ebuild
new file mode 100644
index 0000000..5878dff
--- /dev/null
+++ b/app-admin/system-config-keyboard/system-config-keyboard-1.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2004-2010 Sabayon
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI="2"
+inherit base python
+
+DESCRIPTION="Fedora legacy keyboard management tool."
+HOMEPAGE="https://fedorahosted.org/system-config-keyboard/wiki"
+SRC_URI="https://fedorahosted.org/released/system-config-keyboard/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+DEPEND="dev-util/intltool
+ sys-devel/gettext
+ dev-util/desktop-file-utils"
+RDEPEND="app-admin/firstboot"
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-admin/system-config-users/Manifest b/app-admin/system-config-users/Manifest
new file mode 100644
index 0000000..18fa48e
--- /dev/null
+++ b/app-admin/system-config-users/Manifest
@@ -0,0 +1,3 @@
+AUX system-config-users-kill-rpm.patch 1636 RMD160 312f1b834791012fe6cf3771d9f41866749f5723 SHA1 3b6028df1bb06b2299e4fc3f616f55771371b5c0 SHA256 53a1fad5bcd2d8dbfef3628afb7507ceb2b8e67325f4d6cd76cc9a07f5361cd4
+DIST system-config-users-1.2.96.tar.bz2 261231 RMD160 de898929d33f78335870b9fcf0f72ab2c1b1d390 SHA1 45c0267752647bccfa139d569c83fe2af994b816 SHA256 01ecd4b4f485c8fd3b92fe6a4bfbf1b81cb60b455593b9502a29580077440356
+EBUILD system-config-users-1.2.96-r2.ebuild 1368 RMD160 a43953b3ed4e4b6850b410e573f5d97ddf79b0ce SHA1 035754f735d9864022c53cee5fe4d38d014f4941 SHA256 e63f27ebe2786fc671daf7bb03cfe3f8d00c6b5d88fc34ab9468b6b3f8667856
diff --git a/app-admin/system-config-users/files/system-config-users-kill-rpm.patch b/app-admin/system-config-users/files/system-config-users-kill-rpm.patch
new file mode 100644
index 0000000..4913c32
--- /dev/null
+++ b/app-admin/system-config-users/files/system-config-users-kill-rpm.patch
@@ -0,0 +1,35 @@
+diff -Nurp system-config-users-1.2.96.orig/src/mainWindow.py system-config-users-1.2.96/src/mainWindow.py
+--- system-config-users-1.2.96.orig/src/mainWindow.py 2010-03-31 11:38:17.000000000 +0200
++++ system-config-users-1.2.96/src/mainWindow.py 2010-04-11 17:53:45.060057458 +0200
+@@ -26,7 +26,6 @@ import gobject
+ import gtk.glade
+ import string
+ import os
+-import rpm
+ import shutil
+
+ import libuser
+@@ -652,9 +651,6 @@ class mainWindow:
+ dlg.run ()
+ dlg.destroy ()
+ return
+- ts = rpm.TransactionSet ()
+- if ts.dbMatch ("basenames", homeDir).count () > 0 or ts.dbMatch ("basenames", os.path.abspath (homeDir)).count () > 0 or ts.dbMatch ("basenames", os.path.realpath (homeDir)).count () > 0:
+- errMsgs.append (_("- An installed software package contains this directory."))
+ if uid < 500 or (user == "nfsnobody" and (long (uid) == 65534L or long (uid) == 4294967294L)):
+ errMsgs.append (_("- A system user owns this directory and removing it may impair the system's integrity."))
+ if not os.access(homeDir, os.W_OK):
+@@ -910,12 +906,7 @@ class mainWindow:
+ self.on_properties_activate()
+
+ def isSELinuxInstalled(self):
+- ts = rpm.TransactionSet()
+-
+- mi = ts.dbMatch('name', 'policy-sources')
+- if mi.count() > 0:
+- return True
+- return False
++ return os.path.lexists("/usr/sbin/getenforce") and os.access("/usr/sbin/getenforce", os.X_OK)
+
+ def isSELinuxEnabled(self):
+ if self.isSELinuxInstalled():
diff --git a/app-admin/system-config-users/system-config-users-1.2.96-r2.ebuild b/app-admin/system-config-users/system-config-users-1.2.96-r2.ebuild
new file mode 100644
index 0000000..47a8247
--- /dev/null
+++ b/app-admin/system-config-users/system-config-users-1.2.96-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2004-2010 Sabayon
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI="2"
+inherit python base
+
+DESCRIPTION="The system-config-users tool lets you manage the users and groups on your computer."
+HOMEPAGE="http://fedoraproject.org/wiki/SystemConfig/users"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-1"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="X"
+
+DEPEND="dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-apps/findutils
+ sys-devel/gettext"
+
+# FIXME: would require rpm-python
+RDEPEND="
+ X? ( >=dev-python/pygtk-2.6
+ x11-misc/xdg-utils
+ )
+ >=sys-libs/libuser-0.56
+ sys-libs/cracklib
+ sys-process/procps"
+
+PATCHES=( "${FILESDIR}/${PN}-kill-rpm.patch" )
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
+
+# FIXME: this package should depend against sys-apps/usermode
+# which has been removed from Portage in May, 2009.
+# If you intend to provide a full package in future (and not
+# just stuff required by app-admin/anaconda, please consider
+# to re-add sys-apps/usermode (version bumping, QA checking)
+# and remove the hackish code in src_install below
+src_install() {
+ base_src_install
+
+ # See FIXME above
+ rm -rf "${D}/usr/share/"{man,applications}
+ rm -rf "${D}/etc/"{pam.d,sysconfig,security}
+ rm -rf "${D}/etc/sysconfig"
+ rm -rf "${D}/usr/bin"
+ find "${D}" -name "*.pyc" | xargs rm -f
+}