summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5bfcad80..63a2ec4f 100644
--- a/Makefile
+++ b/Makefile
@@ -65,6 +65,7 @@ install:
layout-dirs:
# Create base filesytem layout
for x in $(KEEP_DIRS) ; do \
+ test -e $(DESTDIR)$$x/.keep && continue ; \
$(INSTALL_DIR) $(DESTDIR)$$x || exit $$? ; \
touch $(DESTDIR)$$x/.keep || echo "ignoring touch failure; mounted fs?" ; \
done