summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-29 12:55:58 +0100
committerJustin Lecher <jlec@gentoo.org>2014-01-29 12:55:58 +0100
commit0f11efdd6adbeaa6b069c5411666119a05b0ce68 (patch)
treec810a425f0bf7a139fd35be46cf18b9d498f08d3 /dev-vcs
parentdev-vcs/rapidsvn: Fix S after moce to git (diff)
downloadbetagarden-0f11efdd6adbeaa6b069c5411666119a05b0ce68.tar.gz
betagarden-0f11efdd6adbeaa6b069c5411666119a05b0ce68.tar.bz2
betagarden-0f11efdd6adbeaa6b069c5411666119a05b0ce68.zip
dev-vcs/git-cola: Fix broken documentation paths, #499658
Package-Manager: portage-2.2.8-r1
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/ChangeLog3
-rw-r--r--dev-vcs/git-cola/git-cola-9999.ebuild14
2 files changed, 15 insertions, 2 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index 429dda1..21e257c 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cola/ChangeLog,v 1.8 2011/04/13 19:00:02 jlec Exp $
+ 29 Jan 2014; Justin Lecher <jlec@gentoo.org> git-cola-9999.ebuild:
+ Fix broken documentation paths, #499658
+
15 Jan 2014; Justin Lecher <jlec@gentoo.org> git-cola-9999.ebuild,
-files/9999-system-ssh-askpass.patch,
+files/git-cola-9999-disable-tests.patch,
diff --git a/dev-vcs/git-cola/git-cola-9999.ebuild b/dev-vcs/git-cola/git-cola-9999.ebuild
index 2aa4631..e5cfd8c 100644
--- a/dev-vcs/git-cola/git-cola-9999.ebuild
+++ b/dev-vcs/git-cola/git-cola-9999.ebuild
@@ -29,13 +29,22 @@ DEPEND="${RDEPEND}
app-text/xmlto
sys-devel/gettext
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ sys-apps/net-tools
+ )"
PATCHES=(
"${FILESDIR}"/${P}-disable-tests.patch
"${FILESDIR}"/${P}-system-ssh-askpass.patch
)
+pkg_pretend() {
+ if use test && [[ -z "$(hostname -d)" ]] ; then
+ die "Test will fail if no domain is set"
+ fi
+}
+
python_prepare_all() {
rm share/git-cola/bin/*askpass* || die
@@ -48,7 +57,7 @@ python_prepare_all() {
setup.py || die "sed failed"
sed -i \
- -e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
+ -e "s|'doc', 'git-cola'|'doc', '${PF}'|" \
cola/resources.py || die "sed failed"
distutils-r1_python_prepare_all
@@ -80,6 +89,7 @@ python_install_all() {
fi
distutils-r1_python_install_all
+ docompress /usr/share/doc/${PF}/git-cola.txt
}
python_test() {