summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xsw/xsw-0.3.5.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/x11-misc/xsw/xsw-0.3.5.ebuild b/x11-misc/xsw/xsw-0.3.5.ebuild
index b8c6c5e..457616e 100644
--- a/x11-misc/xsw/xsw-0.3.5.ebuild
+++ b/x11-misc/xsw/xsw-0.3.5.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit base autotools
+inherit autotools
DESCRIPTION="Slide show presentation tool"
-
HOMEPAGE="http://code.google.com/p/xsw/"
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
@@ -15,19 +14,22 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="pdf"
-DEPEND="media-libs/libsdl
+DEPEND="
+ media-libs/libsdl
media-libs/sdl-ttf
media-libs/sdl-image
media-libs/sdl-gfx"
RDEPEND="${DEPEND}
pdf? ( media-gfx/imagemagick )"
+PATCHES=( "${FILESDIR}"/${PN}-0.3.5-fix-destdir-remove-usr-local-stuff.patch )
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.3.5-fix-destdir-remove-usr-local-stuff.patch
+ default
eautomake
}
src_install() {
- base_src_install
- dodoc ChangeLog NEWS README REFERENCE THANKS TODO || die 'dodoc failed'
+ default
+ dodoc REFERENCE
}