aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--src/CMakeLists.txt10
-rw-r--r--src/Qt/CMakeLists.txt2
3 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e9823d2..d79eef3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,4 +4,6 @@ cmake_minimum_required(VERSION 2.8)
set(CMAKE_MODULE_PATH ${c-portage_SOURCE_DIR}/cmake)
find_package(PortageApi REQUIRED)
+option(Qt4 "Enable c++ wrapper for c-portage (uses Qt4)")
+
add_subdirectory(src)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3fb5b8b..472f2a9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -4,8 +4,8 @@ include_directories(${PYTHON_INCLUDE_DIRS})
link_directories(${PYTHON_LIBRARIES})
add_definitions(-std=c99)
-set(c-portage_SRCS dataconnect.c dict.c flag.c interpreter.c packageproperties.c stringlist.c)
-set(c-portage_HDRS dataconnect.h dict.h flag.h internal.h interpreter.h packageproperties.h stringlist.h)
+set(c-portage_SRCS dataconnect.c dict.c flag.c interpreter.c packageproperties.c portagesettings.c stringlist.c)
+set(c-portage_HDRS dataconnect.h dict.h flag.h internal.h interpreter.h packageproperties.h portage.h portagesettings.h stringlist.h)
add_library(c-portage SHARED ${c-portage_SRCS})
target_link_libraries(c-portage ${PYTHON_LIBRARY})
@@ -15,8 +15,6 @@ target_link_libraries(tester c-portage)
install(TARGETS c-portage DESTINATION lib)
install(FILES ${c-portage_HDRS} DESTINATION include/c-portage)
-option(CppPortage "Enable c++ wrapper for c-portage (uses Qt4)")
-
-if (CppPortage)
+if (Qt4)
add_subdirectory(Qt)
-endif(CppPortage)
+endif(Qt4)
diff --git a/src/Qt/CMakeLists.txt b/src/Qt/CMakeLists.txt
index d673e61..1ffc149 100644
--- a/src/Qt/CMakeLists.txt
+++ b/src/Qt/CMakeLists.txt
@@ -7,7 +7,7 @@ set(cpp-portage_HDRS helper.h qportage.h qportagesettings.h qpackageproperties.h
QT4_WRAP_CPP(cpp-portage_MOC_SRCS ${cpp-portage_HDRS})
-add_library(cpp-portage SHARED qportagesettings.cpp ${cpp-portage_MOC_SRCS})
+add_library(cpp-portage SHARED ${cpp-portage_SRCS} ${cpp-portage_MOC_SRCS})
target_link_libraries(cpp-portage c-portage ${QT_QTCORE_LIBRARY})
install(TARGETS cpp-portage DESTINATION lib)