aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2017-04-17 09:01:31 -0500
committerDoug Goldstein <cardoe@cardoe.com>2017-04-17 09:01:31 -0500
commitb5a1a469c8e380fdd095536d4e4bac3c1258dc14 (patch)
treec8251cd3b8cde4e580f9648f4c96ab50484b111d
parentupgrade to Cargo 0.16 to support workspaces (diff)
downloadcargo-ebuild-b5a1a469c8e380fdd095536d4e4bac3c1258dc14.tar.gz
cargo-ebuild-b5a1a469c8e380fdd095536d4e4bac3c1258dc14.tar.bz2
cargo-ebuild-b5a1a469c8e380fdd095536d4e4bac3c1258dc14.zip
update Cargo.toml for new fields
Added newer fields that crates.io understands and add an API link to docs.rs since most people will be interested in how to use the command instead of the API.
-rw-r--r--Cargo.toml4
-rw-r--r--README.md4
2 files changed, 8 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0c8ebcb..2f84a4d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,10 +8,14 @@ homepage = "https://github.com/cardoe/cargo-ebuild"
documentation = "https://github.com/cardoe/cargo-ebuild"
readme = "README.md"
keywords = ["cargo-subcommand", "ebuild", "gentoo"]
+categories = ["command-line-utilities"]
description = """
Generates an ebuild for a package using the in-tree eclasses.
"""
+[badges]
+travis-ci = { repository = "cardoe/cargo-ebuild" }
+
[dependencies]
cargo = "0.16"
rustc-serialize = "^0.3"
diff --git a/README.md b/README.md
index 79f46e3..59b63d8 100644
--- a/README.md
+++ b/README.md
@@ -98,3 +98,7 @@ IUSE=""
DEPEND=""
RDEPEND=""
```
+
+## API
+
+API documentation is available at [docs.rs](https://docs.rs/cargo-ebuild/).