aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2019-12-26 13:18:56 -0600
committerDoug Goldstein <cardoe@cardoe.com>2020-01-26 09:20:19 -0600
commitd69ca8ce27e2ab3c64c06b2ff5b61895b35a1afc (patch)
tree207540fc6bc875a3febfdcc3a389bbb9f81de082
parentsplit metadata gathering and ebuild writing functions (diff)
downloadcargo-ebuild-d69ca8ce27e2ab3c64c06b2ff5b61895b35a1afc.tar.gz
cargo-ebuild-d69ca8ce27e2ab3c64c06b2ff5b61895b35a1afc.tar.bz2
cargo-ebuild-d69ca8ce27e2ab3c64c06b2ff5b61895b35a1afc.zip
drop unused verbose and quiet flags
The verbose and quiet flags don't do anything so drop these as valid flags.
-rw-r--r--src/lib.rs6
-rw-r--r--src/main.rs9
2 files changed, 2 insertions, 13 deletions
diff --git a/src/lib.rs b/src/lib.rs
index 9e380ec..2eff106 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -27,11 +27,7 @@ fn parse_license<'a>(lic_str: &'a str) -> Vec<&'a str> {
.collect()
}
-pub fn gen_ebuild_data(
- verbose: u32,
- quiet: bool,
- manifest_path: Option<PathBuf>,
-) -> Result<EbuildConfig> {
+pub fn gen_ebuild_data(manifest_path: Option<PathBuf>) -> Result<EbuildConfig> {
let mut cmd = cargo_metadata::MetadataCommand::new();
if let Some(path) = manifest_path {
diff --git a/src/main.rs b/src/main.rs
index bc3c520..dbf73ee 100644
--- a/src/main.rs
+++ b/src/main.rs
@@ -19,13 +19,6 @@ use structopt::StructOpt;
#[derive(StructOpt, Debug)]
struct Args {
- /// Silence all output
- #[structopt(short = "q", long = "quiet")]
- quiet: bool,
- /// Verbose mode (-v, -vv, -vvv, etc.)
- #[structopt(short = "v", long = "verbose", parse(from_occurrences))]
- verbose: usize,
-
#[structopt(name = "PATH", long = "manifest-path", parse(from_os_str))]
/// Path to Cargo.toml.
manifest_path: Option<PathBuf>,
@@ -49,7 +42,7 @@ fn main() -> Result<()> {
let Opt::Ebuild(opt) = Opt::from_args();
// compute the data from the package that the build needs
- let ebuild_data = gen_ebuild_data(opt.verbose as u32, opt.quiet, opt.manifest_path)?;
+ let ebuild_data = gen_ebuild_data(opt.manifest_path)?;
let ebuild_path = format!("{}-{}.ebuild", ebuild_data.name, ebuild_data.version);