aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-11-22 20:47:35 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-11-22 20:47:35 +0000
commitc6351397752a3e59279fe628b5ac92bf5eac5eee (patch)
treed731f7aef7fcd0bd52ac31f76a8aab357dd60b6c /examples
parentTinderbox script: added newuse, tinderbox and grp targets added support for o... (diff)
downloadcatalyst-c6351397752a3e59279fe628b5ac92bf5eac5eee.tar.gz
catalyst-c6351397752a3e59279fe628b5ac92bf5eac5eee.tar.bz2
catalyst-c6351397752a3e59279fe628b5ac92bf5eac5eee.zip
Added tinderbox_template.spec to examples and cleaned up pkgcache_path definitions in the examples to fit in 80 columns.
git-svn-id: svn+ssh://svn.gentoo.org/var/svnroot/catalyst/trunk@909 d1e1f19c-881f-0410-ab34-b69fee027534
Diffstat (limited to 'examples')
-rw-r--r--examples/grp_template.spec7
-rw-r--r--examples/livecd-stage1_template.spec7
-rw-r--r--examples/stage4_template.spec7
-rw-r--r--examples/tinderbox_template.spec80
4 files changed, 92 insertions, 9 deletions
diff --git a/examples/grp_template.spec b/examples/grp_template.spec
index 2bcaf6eb..3e5e3163 100644
--- a/examples/grp_template.spec
+++ b/examples/grp_template.spec
@@ -56,9 +56,10 @@ distcc_hosts:
# portage_confdir: /etc/portage
portage_confdir:
-# This allows the optional directory containing the output packages for catalyst.
-# Mainly used as a way for different spec files to access the same cache directory
-# Default behavior is for this location to be autogenerated by catalyst based on the spec file.
+# This allows the optional directory containing the output packages for
+# catalyst. Mainly used as a way for different spec files to access the same
+# cache directory. Default behavior is for this location to be autogenerated
+# by catalyst based on the spec file.
# example:
# pkgcache_path: /tmp/packages
pkgcache_path:
diff --git a/examples/livecd-stage1_template.spec b/examples/livecd-stage1_template.spec
index 69241594..3795fa53 100644
--- a/examples/livecd-stage1_template.spec
+++ b/examples/livecd-stage1_template.spec
@@ -56,9 +56,10 @@ distcc_hosts:
# portage_confdir: /etc/portage
portage_confdir:
-# This allows the optional directory containing the output packages for catalyst.
-# Mainly used as a way for different spec files to access the same cache directory
-# Default behavior is for this location to be autogenerated by catalyst based on the spec file.
+# This allows the optional directory containing the output packages for
+# catalyst. Mainly used as a way for different spec files to access the same
+# cache directory. Default behavior is for this location to be autogenerated
+# by catalyst based on the spec file.
# example:
# pkgcache_path: /tmp/packages
pkgcache_path:
diff --git a/examples/stage4_template.spec b/examples/stage4_template.spec
index 8de0415a..c6feb666 100644
--- a/examples/stage4_template.spec
+++ b/examples/stage4_template.spec
@@ -56,9 +56,10 @@ distcc_hosts:
# portage_confdir: /etc/portage
portage_confdir:
-# This allows the optional directory containing the output packages for catalyst.
-# Mainly used as a way for different spec files to access the same cache directory
-# Default behavior is for this location to be autogenerated by catalyst based on the spec file.
+# This allows the optional directory containing the output packages for
+# catalyst. Mainly used as a way for different spec files to access the same
+# cache directory. Default behavior is for this location to be autogenerated
+# by catalyst based on the spec file.
# example:
# pkgcache_path: /tmp/packages
pkgcache_path:
diff --git a/examples/tinderbox_template.spec b/examples/tinderbox_template.spec
new file mode 100644
index 00000000..db09899e
--- /dev/null
+++ b/examples/tinderbox_template.spec
@@ -0,0 +1,80 @@
+# generic tinderbox specfile
+
+# The subarch can be any of the supported catalyst subarches (like athlon-xp).
+# Refer to the catalyst reference manual for suppurted subarches.
+# http://www.gentoo.org/proj/en/releng/catalyst/reference.xml
+# example:
+# subarch: athlon-xp
+subarch:
+
+# The version stamp is an identifier for the build. It can be anything you wish# it to be, but it is usually a date.
+# example:
+# version_stamp: 2005.0
+version_stamp:
+
+# The target specifies what target we want catalyst to do.
+# example:
+# target: tinderbox
+target: tinderbox
+
+# The rel_type defines what kind of build we are doing. This is merely another
+# identifier, but it useful for allowing multiple concurrent builds. Usually,
+# default will suffice.
+# example:
+# rel_type: default
+rel_type:
+
+# This is the system profile to be used by catalyst to build this target. It is# specified as a relative path from /usr/portage/profiles.
+# example:
+# profile: default-linux/x86/2005.0
+profile:
+
+# This specifies which snapshot to use for building this target.
+# example:
+# snapshot: 20050324
+snapshot:
+
+# This specifies where the seed stage comes from for this target, The path is
+# relative to $clst_sharedir/builds. The rel_type is also used as a path prefix# for the seed.
+# example:
+# default/stage3-x86-2004.3
+source_subpath:
+
+# These are the hosts used as distcc slaves when distcc is enabled in your
+# catalyst.conf. It follows the same syntax as distcc-config --set-hosts and
+# is entirely optional.
+# example:
+# distcc_hosts: 127.0.0.1 192.168.0.1
+distcc_hosts:
+
+# This is an optional directory containing portage configuration files. It
+# follows the same syntax as /etc/portage and should be consistent across all
+# targets to minimize problems.
+# example:
+# portage_confdir: /etc/portage
+portage_confdir:
+
+# This allows the optional directory containing the output packages for
+# catalyst. Mainly used as a way for different spec files to access the same
+# cache directory. Default behavior is for this location to be autogenerated
+# by catalyst based on the spec file.
+# example:
+# pkgcache_path: /tmp/packages
+pkgcache_path:
+
+# The tinderbox target can build packages with any USE settings. However, it
+# should be noted that these settings are additive to the settings in the
+# chosen profile. This is extremely useful when testing possible changed to a
+# profile or package.
+# example:
+# tinderbox/use: gtk2 gnome kde qt bonobo cdr esd gtkhtml mozilla mysql perl ruby tcltk cups ldap ssl tcpd -svga
+tinderbox/use:
+
+# This is the list of packages that will be built by the tinderbox target.
+# Each of these is considered a separate target to test, and catalyst will use
+# rsync to reset the build area to the default from the source_subpath before
+# each package. This allows for testing USE changes on individual packages as
+# well as for dependency issues.
+# exampleL
+# tinderbox/packages: dante tsocks sys-apps/eject minicom links acpid apmd parted whois tcpdump cvs zip unzip netcat partimage app-admin/sudo app-cdr/cdrtools gnome emacs dev-lang/ruby enlightenment kde mozilla-firefox mozilla-thunderbird xfce4 openbox fluxbox sylpheed openoffice-bin gimp xemacs xmms abiword gaim xchat pan tetex xcdroast k3b samba nmap gradm ettercap ethereal mplayer
+tinderbox/packages: