aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2013-07-30 00:04:51 -0700
committerMatt Turner <mattst88@gmail.com>2013-07-30 00:08:15 -0700
commitc0fcbf027169da8b6f0d5e3c80c1526642c6c672 (patch)
treea607cff9d5562f06322daae95de1ef5c0a32beb2 /targets
parentRemove ChangeLog. (diff)
downloadcatalyst-c0fcbf027169da8b6f0d5e3c80c1526642c6c672.tar.gz
catalyst-c0fcbf027169da8b6f0d5e3c80c1526642c6c672.tar.bz2
catalyst-c0fcbf027169da8b6f0d5e3c80c1526642c6c672.zip
kmerge.sh: Don't set USE=build for emerging kernels.
USE=build for kernels means that they're not going to be built and that we just want to install the sources. In catalyst, we do also want to build the kernels, so settings the (badly named) USE flag prevents installing sys-devel/bc, ultimately leading to the kernel build failing. Remove USE=build from kmerge.sh and let it install dependencies necessary for actually building the kernel. Fixes Live CD builds with kernels that require bc (>= 3.9, I believe). See bug 478244. Tested-by: Ben Kohler <bkohler@gmail.com>
Diffstat (limited to 'targets')
-rw-r--r--targets/support/kmerge.sh4
1 files changed, 0 insertions, 4 deletions
diff --git a/targets/support/kmerge.sh b/targets/support/kmerge.sh
index e78e0b49..364d2264 100644
--- a/targets/support/kmerge.sh
+++ b/targets/support/kmerge.sh
@@ -196,9 +196,6 @@ then
fi
fi
-[ -e /etc/portage/make.conf ] && \
- echo "USE=\"\${USE} ${clst_kernel_use} build\"" >> /etc/portage/make.conf
-
if [ -n "${clst_KERNCACHE}" ]
then
mkdir -p /tmp/kerncache/${clst_kname}
@@ -237,7 +234,6 @@ then
fi
build_kernel
-sed -i "/USE=\"\${USE} ${clst_kernel_use} build\"/d" /etc/portage/make.conf
# grep out the kernel version so that we can do our modules magic
VER=`grep ^VERSION\ \= /usr/src/linux/Makefile | awk '{ print $3 };'`
PAT=`grep ^PATCHLEVEL\ \= /usr/src/linux/Makefile | awk '{ print $3 };'`