aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux.gentoo.org>2012-02-06 11:40:45 +0100
committerJosé María Alonso <nimiux.gentoo.org>2012-02-06 11:40:45 +0100
commitf66bad59d20e6a10b8cb1d0808f6c6004b8628fa (patch)
tree8df3ddc1699cf140b9bba780bebc29e2879c23ca
parentAdded description of the tool (diff)
downloadconf-update-f66bad59d20e6a10b8cb1d0808f6c6004b8628fa.tar.gz
conf-update-f66bad59d20e6a10b8cb1d0808f6c6004b8628fa.tar.bz2
conf-update-f66bad59d20e6a10b8cb1d0808f6c6004b8628fa.zip
Added install phase1.0.2
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5ff7614..b8bbb7a 100644
--- a/Makefile
+++ b/Makefile
@@ -21,8 +21,16 @@ conf-update.h: core.h helpers.h index.h modified.h config.h
conf-update: core.o helpers.o conf-update.o index.o modified.o config.o
$(CC) $(LDFLAGS) -o conf-update config.o core.o helpers.o conf-update.o index.o modified.o $$(pkg-config --libs glib-2.0) -lncurses -lmenu -lcrypto
-.PHONY: clean
+install: conf-update
+ @install -d $(DESTDIR)/usr/sbin/
+ @install conf-update $(DESTDIR)/usr/sbin/
+ @install -d $(DESTDIR)/etc
+ @install -m 644 conf-update.conf $(DESTDIR)/etc
+ @install -d $(DESTDIR)/usr/share/man/man1
+ @install -m 644 conf-update.1 $(DESTDIR)/usr/share/man/man1
clean:
rm -f *.o
rm -f conf-update
+
+.PHONY: all clean