summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMauro Toffanin <toffanin.mauro@gmail.com>2010-01-10 19:25:42 +0100
committerMauro Toffanin <toffanin.mauro@gmail.com>2010-01-10 19:25:42 +0100
commitbaff32c0f3bbf39d4de528f4f18e00f9b63d4a57 (patch)
tree17faeb50fc460bbb3a93faabf0eead7d171b73e9
parentImplemented a better dir structure for the themes (diff)
downloaddevmanual-baff32c0f3bbf39d4de528f4f18e00f9b63d4a57.tar.gz
devmanual-baff32c0f3bbf39d4de528f4f18e00f9b63d4a57.tar.bz2
devmanual-baff32c0f3bbf39d4de528f4f18e00f9b63d4a57.zip
Fixing font paths and improving xsl stylesheet
-rw-r--r--Makefile.docbook5
-rw-r--r--public/css-themes/localhost-html/styles/main.css2
-rw-r--r--public/css-themes/localhost-html/styles/typefacing.css18
-rw-r--r--stylesheets/localhost.xsl46
4 files changed, 39 insertions, 32 deletions
diff --git a/Makefile.docbook b/Makefile.docbook
index ae77235..3118fd6 100644
--- a/Makefile.docbook
+++ b/Makefile.docbook
@@ -3,7 +3,8 @@ XSLTPROC = xsltproc
XSL-NS-SS = http://docbook.sourceforge.net/release/xsl-ns/current/
BASEURI := $(shell pwd)/public/
-CSS_THEME_NAME := localhost-html/
+CSS_THEME_NAME := localhost-html
+
generate: main.docbook
$(XSLTPROC) \
--xinclude \
@@ -16,7 +17,7 @@ generate: main.docbook
--stringparam collect.xref.targets "yes" \
--stringparam targets.filename "$(patsubst %.xhtml,%.olinkdb,$@)" \
--stringparam css.theme.name "${CSS_THEME_NAME}" \
- stylesheets/gentoo.org.xsl $<
+ stylesheets/localhost.xsl $<
chunk.toc.new:
$(XSLTPROC) \
diff --git a/public/css-themes/localhost-html/styles/main.css b/public/css-themes/localhost-html/styles/main.css
index f24610d..acd0b21 100644
--- a/public/css-themes/localhost-html/styles/main.css
+++ b/public/css-themes/localhost-html/styles/main.css
@@ -28,7 +28,7 @@ hr {
}
p {
text-align:justify;
- text-indent:30px;
+/* text-indent:30px;*/
}
a {
/* Resetting borders from the DocBook template */
diff --git a/public/css-themes/localhost-html/styles/typefacing.css b/public/css-themes/localhost-html/styles/typefacing.css
index e61f9a1..3952667 100644
--- a/public/css-themes/localhost-html/styles/typefacing.css
+++ b/public/css-themes/localhost-html/styles/typefacing.css
@@ -11,33 +11,33 @@
/** Sans font sets **/
@font-face {
font-family: 'DroidSans';
- src: url('../fonts/DroidSans.ttf') format('truetype');
+ src: url('/usr/share/fonts/droid/DroidSans.ttf') format('truetype');
}
@font-face {
font-family: 'DroidSans-Bold';
- src: url('../fonts/DroidSans-Bold.ttf') format('truetype');
+ src: url('/usr/share/fonts/droid/DroidSans-Bold.ttf') format('truetype');
}
@font-face {
font-family: 'DoridSans-Mono';
- src: url('../fonts/DroidSansMono.ttf') format('truetype');
+ src: url('/usr/share/fonts/droid/DroidSansMono.ttf') format('truetype');
}
/** Sans Serif font sets **/
@font-face {
font-family: 'DroidSerif-BoldItalic';
- src: url('../fonts/DroidSerif-BoldItalic.ttf') format('truetype');
+ src: url('/usr/share/fonts/droid/DroidSerif-BoldItalic.ttf') format('truetype');
}
@font-face {
font-family: 'DroidSerif-Bold';
- src: url('../fonts/DroidSerif-Bold.ttf') format('truetype');
+ src: url('/usr/share/fonts/droid/DroidSerif-Bold.ttf') format('truetype');
}
@font-face {
font-family: 'DroidSerif-Regular';
- src: url('../fonts/DroidSerif-Regular.ttf') format('truetype');
+ src: url('/usr/share/fonts/droid/DroidSerif-Regular.ttf') format('truetype');
}
@font-face {
font-family: 'DroidSerif-Italic';
- src: url('../fonts/DroidSerif-Italic.ttf') format('truetype');
+ src: url('/usr/share/fonts/droid/DroidSerif-Italic.ttf') format('truetype');
}
/** Typefacing elements **/
@@ -51,7 +51,7 @@ body {
}
.amp, em {
/* font-family:Baskerville,Georgia,'Times New Roman,sans-serif;*/
- font-family:'DroidSerif-Italic';
+ font-style:italic;
}
a {
font-family:'DroidSans-Bold';
@@ -64,7 +64,7 @@ para {
/** DocBook classes **/
.legalnotice {
- font-family: 'DroidSerif-Italic';
+ font-style:italic;
}
.programlisting {
/* font-family:'DroidSans-Mono','Consolas','Bitstream Vera Sans Mono','Courier New',Courier,monospace !important;*/
diff --git a/stylesheets/localhost.xsl b/stylesheets/localhost.xsl
index eb96ba8..ed48867 100644
--- a/stylesheets/localhost.xsl
+++ b/stylesheets/localhost.xsl
@@ -9,10 +9,11 @@
<!-- List of the configurable parameters -->
<xsl:param name="baseuri"></xsl:param>
-<xsl:param name="theme-name">web/</xsl:param>
-<xsl:param name="css-path">css/</xsl:param>
-<xsl:param name="js-path">js/</xsl:param>
-<xsl:param name="images-path">images/</xsl:param>
+<xsl:param name="css.themes.path" select="'css-themes/'"></xsl:param>
+<xsl:param name="css.theme.name" select="'localhost-html'"></xsl:param>
+<xsl:param name="css.styles.path" select="'styles/'"></xsl:param>
+<xsl:param name="css.js.path" select="'js/'"></xsl:param>
+<xsl:param name="css.images.path" select="'images/'"></xsl:param>
<xsl:template name="user.head.content">
<!-- Include the reset Style Sheet
@@ -22,9 +23,10 @@
<link rel="stylesheet" type="text/css">
<xsl:attribute name="href">
<xsl:value-of select="$baseuri" />
- <xsl:text>stylesheets/</xsl:text>
- <xsl:value-of select="$theme-name" />
- <xsl:value-of select="$css-path" />
+ <xsl:value-of select="$css.themes.path" />
+ <xsl:value-of select="$css.theme.name" />
+ <xsl:text>/</xsl:text>
+ <xsl:value-of select="$css.styles.path" />
<xsl:text>reset.css</xsl:text>
</xsl:attribute>
</link>
@@ -34,10 +36,11 @@
<link rel="stylesheet" type="text/css">
<xsl:attribute name="href">
<xsl:value-of select="$baseuri" />
- <xsl:text>stylesheets/</xsl:text>
- <xsl:value-of select="$theme-name" />
- <xsl:value-of select="$css-path" />
- <xsl:text>style.css</xsl:text>
+ <xsl:value-of select="$css.themes.path" />
+ <xsl:value-of select="$css.theme.name" />
+ <xsl:text>/</xsl:text>
+ <xsl:value-of select="$css.styles.path" />
+ <xsl:text>main.css</xsl:text>
</xsl:attribute>
</link>
@@ -47,9 +50,10 @@
<link rel="stylesheet" type="text/css">
<xsl:attribute name="href">
<xsl:value-of select="$baseuri" />
- <xsl:text>stylesheets/</xsl:text>
- <xsl:value-of select="$theme-name" />
- <xsl:value-of select="$css-path" />
+ <xsl:value-of select="$css.themes.path" />
+ <xsl:value-of select="$css.theme.name" />
+ <xsl:text>/</xsl:text>
+ <xsl:value-of select="$css.styles.path" />
<xsl:text>typefacing.css</xsl:text>
</xsl:attribute>
</link>
@@ -59,9 +63,10 @@
<link rel="stylesheet" type="text/css">
<xsl:attribute name="href">
<xsl:value-of select="$baseuri" />
- <xsl:text>stylesheets/</xsl:text>
- <xsl:value-of select="$theme-name" />
- <xsl:value-of select="$css-path" />
+ <xsl:value-of select="$css.themes.path" />
+ <xsl:value-of select="$css.theme.name" />
+ <xsl:text>/</xsl:text>
+ <xsl:value-of select="$css.styles.path" />
<xsl:text>grid.css</xsl:text>
</xsl:attribute>
</link>
@@ -77,9 +82,10 @@
<script type="text/javascript">
<xsl:attribute name="src">
<xsl:value-of select="$baseuri" />
- <xsl:text>stylesheets/</xsl:text>
- <xsl:value-of select="$theme-name" />
- <xsl:value-of select="$js-path" />
+ <xsl:value-of select="$css.themes.path" />
+ <xsl:value-of select="$css.theme.name" />
+ <xsl:text>/</xsl:text>
+ <xsl:value-of select="$css.js.path" />
<xsl:text>hashgrid.js</xsl:text>
</xsl:attribute>
</script>