aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMauro Toffanin <toffanin.mauro@gmail.com>2010-01-07 19:07:56 +0100
committerMauro Toffanin <toffanin.mauro@gmail.com>2010-01-07 19:07:56 +0100
commitfcfd6fe823d46cd19b618243a002319c4d8291fa (patch)
treee2aa6a524116099271d6062d52cb9fafc9ea5299
parentMore sections converted. (diff)
downloaddevmanual-fcfd6fe823d46cd19b618243a002319c4d8291fa.tar.gz
devmanual-fcfd6fe823d46cd19b618243a002319c4d8291fa.tar.bz2
devmanual-fcfd6fe823d46cd19b618243a002319c4d8291fa.zip
First draft of the new gentoo.org stylesheet
-rw-r--r--Makefile.docbook2
-rw-r--r--public/stylesheets/reset.css22
-rw-r--r--public/stylesheets/style.css67
-rw-r--r--public/stylesheets/typefacing.css14
-rw-r--r--stylesheets/gentoo.org.xsl32
5 files changed, 136 insertions, 1 deletions
diff --git a/Makefile.docbook b/Makefile.docbook
index 1c66f72..514d7ef 100644
--- a/Makefile.docbook
+++ b/Makefile.docbook
@@ -12,7 +12,7 @@ generate: main.docbook
--stringparam toc.section.depth 1 \
--stringparam collect.xref.targets "yes" \
--stringparam targets.filename "$(patsubst %.xhtml,%.olinkdb,$@)" \
- $(XSL-NS-SS)/xhtml-1_1/chunktoc.xsl \
+ stylesheets/gentoo.org.xsl \
$<
chunk.toc.new:
diff --git a/public/stylesheets/reset.css b/public/stylesheets/reset.css
new file mode 100644
index 0000000..3a5ff48
--- /dev/null
+++ b/public/stylesheets/reset.css
@@ -0,0 +1,22 @@
+/** Resetting elements */
+/*html, body, div, span, object, iframe,
+h1, h2, h3, h4, h5, h6, p, blockquote, pre,
+a, abbr, acronym, address, code,
+del, dfn, em, img, q, dl, dt, dd, ol, ul, li,
+fieldset, form, label, legend,
+table, caption, tbody, tfoot, thead, tr, th, td, hr {
+ border:0;
+ color:#000000;
+ font-weight:inherit;
+ font-style:inherit;
+ font-size:100%;
+ font-family:inherit;
+ margin:0;
+ outline:none;
+ padding:0;
+ text-decoration:none;
+ vertical-align:baseline;
+}*/
+/* Remove possible quote marks (") from <q>, <blockquote>. */
+blockquote:before, blockquote:after, q:before, q:after { content:"";}
+blockquote, q { quotes:"" "";}
diff --git a/public/stylesheets/style.css b/public/stylesheets/style.css
new file mode 100644
index 0000000..8b9a7d8
--- /dev/null
+++ b/public/stylesheets/style.css
@@ -0,0 +1,67 @@
+/**
+ * Toffanin Mauro - toffanin.mauro@gmail.com
+ * v0.1 - 07.01.2009
+ */
+
+/**
+ * COLORS TABLE:
+ * blue: #0F83DB;
+ */
+
+/** General HTML Elements **/
+body {
+ font-family:Helvetica,"Helvetica Neue","Lucida Grande","Lucida Sans Unicode",Sans-Serif,Verdana,Arial;
+ font-size:1em;
+ max-width:800px;
+ margin:auto;
+ margin-top:50px;
+}
+hr {
+ border:0;
+ border-bottom:4px solid #1A1A1A;
+}
+p {
+ text-align:justify;
+}
+a[href=""] {
+ color:#0F83DB;
+ /* Resetting borders from the DocBook template */
+ text-decoration:none;
+ border:0;
+}
+
+/** General HTML Classes **/
+.legalnotice {
+ border-top:1px solid #1A1A1A;
+ border-bottom:1px solid #1A1A1A;
+}
+.chapter {
+}
+.section {
+}
+.toc > dl > dd {
+ margin-bottom:10px;
+}
+.programlisting {
+ background-color:#F8F8F8;
+ border:1px solid #1A1A1A;
+ border-left:16px solid #1A1A1A;
+ font-family:"Consolas","Bitstream Vera Sans Mono","Courier New",Courier,monospace !important;
+ font-size:0.9em !important;
+ font-style:normal !important;
+ font-weight:normal !important;
+ line-height:1.1em !important;
+ padding:5px;
+
+ -moz-border-radius:8px;
+ -webkit-border-radius:8px;
+ -khtml-border-radius:8px;
+ border-radius:8px; /* leave this CSS tag always as last */
+}
+.programlisting > a {
+ color:#333333;
+}
+.varname, .filename {
+ font-weight:bold;
+ font-size:1.2em;
+}
diff --git a/public/stylesheets/typefacing.css b/public/stylesheets/typefacing.css
new file mode 100644
index 0000000..cac0a6a
--- /dev/null
+++ b/public/stylesheets/typefacing.css
@@ -0,0 +1,14 @@
+/** Typefacing tweaks **/
+html {
+ font-size:100.01%; /* FIX typefacing rendering on broken browsers */
+}
+.amp {
+ font-family:Baskerville,Georgia,"Times New Roman",sans-serif;
+ font-style:italic;
+}
+em {
+ font-style:italic;
+}
+.legalnotice {
+ font-style:italic;
+}
diff --git a/stylesheets/gentoo.org.xsl b/stylesheets/gentoo.org.xsl
new file mode 100644
index 0000000..dd93209
--- /dev/null
+++ b/stylesheets/gentoo.org.xsl
@@ -0,0 +1,32 @@
+<?xml version="1.0"?>
+<xsl:stylesheet
+ xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
+ xmlns:docbook="http://docbook.org/ns/docbook"
+ version="1.0">
+
+<xsl:import href="http://docbook.sourceforge.net/release/xsl-ns/current/xhtml-1_1/chunktoc.xsl" />
+
+<xsl:param name="baseuri"></xsl:param>
+
+<xsl:template name="user.head.content">
+ <link rel="stylesheet" type="text/css">
+ <xsl:attribute name="href">
+ <xsl:value-of select="$baseuri" />
+ <xsl:text>stylesheets/reset.css</xsl:text>
+ </xsl:attribute>
+ </link>
+ <link rel="stylesheet" type="text/css">
+ <xsl:attribute name="href">
+ <xsl:value-of select="$baseuri" />
+ <xsl:text>stylesheets/style.css</xsl:text>
+ </xsl:attribute>
+ </link>
+ <link rel="stylesheet" type="text/css">
+ <xsl:attribute name="href">
+ <xsl:value-of select="$baseuri" />
+ <xsl:text>stylesheets/typefacing.css</xsl:text>
+ </xsl:attribute>
+ </link>
+</xsl:template>
+
+</xsl:stylesheet>