summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'ebuild-writing/functions/pkg_postinst/text.rst')
-rw-r--r--ebuild-writing/functions/pkg_postinst/text.rst35
1 files changed, 35 insertions, 0 deletions
diff --git a/ebuild-writing/functions/pkg_postinst/text.rst b/ebuild-writing/functions/pkg_postinst/text.rst
new file mode 100644
index 0000000..5f87394
--- /dev/null
+++ b/ebuild-writing/functions/pkg_postinst/text.rst
@@ -0,0 +1,35 @@
+pkg_postinst
+============
+
++------------------+---------------------------------------------------+
+| **Function** | ``pkg_postinst`` |
++------------------+---------------------------------------------------+
+| **Purpose** | Called after image is installed to ``${ROOT}`` |
++------------------+---------------------------------------------------+
+| **Sandbox** | Disabled |
++------------------+---------------------------------------------------+
+| **Privilege** | root |
++------------------+---------------------------------------------------+
+| **Called for** | ebuild, binary |
++------------------+---------------------------------------------------+
+
+Default ``pkg_postinst``
+------------------------
+
+.. CODESAMPLE pkg_postinst-1.ebuild
+
+Sample ``pkg_postinst``
+-----------------------
+
+.. CODESAMPLE pkg_postinst-2.ebuild
+
+Common ``pkg_postinst`` Tasks
+-----------------------------
+
+The most common use for ``pkg_postinst`` is to display post-install
+informational messages or warnings. Note that ``has_version`` will operate on
+the version that *was* installed, which can be useful for selective upgrade
+messages.
+
+.. vim: set ft=glep tw=80 sw=4 et spell spelllang=en : ..
+