summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'ebuild-writing/functions/src_compile/configure/use-sample.ebuild')
-rw-r--r--ebuild-writing/functions/src_compile/configure/use-sample.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/ebuild-writing/functions/src_compile/configure/use-sample.ebuild b/ebuild-writing/functions/src_compile/configure/use-sample.ebuild
new file mode 100644
index 0000000..1127543
--- /dev/null
+++ b/ebuild-writing/functions/src_compile/configure/use-sample.ebuild
@@ -0,0 +1,21 @@
+#
+
+src_compile() {
+ # We have optional perl, python and ruby support
+ econf \
+ $(use_enable perl ) \
+ $(use_enable python ) \
+ $(use_enable ruby ) \
+ || die "Configure failed!"
+
+ # ...
+}
+
+src_compile() {
+ # Our package optional IPv6 support which uses --with rather than
+ # --enable / --disable
+
+ econf $(use_with ipv6 ) || die "econf failed!"
+
+ # ...
+}