aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'quickstart/ex1.ebuild')
-rw-r--r--quickstart/ex1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/quickstart/ex1.ebuild b/quickstart/ex1.ebuild
new file mode 100644
index 0000000..31c878d
--- /dev/null
+++ b/quickstart/ex1.ebuild
@@ -0,0 +1,26 @@
+# Example
+
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Exuberant ctags generates tags files for quick source navigation"
+HOMEPAGE="http://ctags.sourceforge.net"
+SRC_URI="mirror://sourceforge/ctags/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~mips ~sparc ~x86"
+IUSE=""
+
+src_compile() {
+ econf --with-posix-regex || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ dodoc FAQ NEWS README
+ dohtml EXTENDING.html ctags.html
+}