aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-07-30 14:55:26 -0400
committerAnthony G. Basile <blueness@gentoo.org>2014-07-30 14:55:26 -0400
commitdfafe78c08ac22bc87c42e64f06a92b55830a689 (patch)
tree815c57004929e41ab0b3170683784cfa03432e28
parentdoc/Makefile.am: fix lost fix-gnustack.1 (diff)
downloadelfix-dfafe78c08ac22bc87c42e64f06a92b55830a689.tar.gz
elfix-dfafe78c08ac22bc87c42e64f06a92b55830a689.tar.bz2
elfix-dfafe78c08ac22bc87c42e64f06a92b55830a689.zip
configure.ac: replace tabs with 4 spaces
-rw-r--r--configure.ac146
1 files changed, 73 insertions, 73 deletions
diff --git a/configure.ac b/configure.ac
index de0cc22..2b66eae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,12 +28,12 @@ LT_INIT([dlopen])
AC_CONFIG_MACRO_DIR([m4])
AC_ARG_ENABLE(
- [tests],
- AS_HELP_STRING(
- [--enable-tests],
- [perform tests]
- ),
- [test "x$enable_tests" = "xyes"]
+ [tests],
+ AS_HELP_STRING(
+ [--enable-tests],
+ [perform tests]
+ ),
+ [test "x$enable_tests" = "xyes"]
)
AM_CONDITIONAL([TEST],[test "x$enable_tests" = "xyes"])
@@ -44,10 +44,10 @@ AC_PROG_SED
# Checks for header files.
AC_CHECK_HEADERS(
- [errno.h err.h fcntl.h gelf.h libgen.h stdio.h stdlib.h string.h \
- sys/mman.h sys/stat.h sys/types.h unistd.h],
- [],
- [AC_MSG_ERROR(["Missing necessary header"])]
+ [errno.h err.h fcntl.h gelf.h libgen.h stdio.h stdlib.h string.h \
+ sys/mman.h sys/stat.h sys/types.h unistd.h],
+ [],
+ [AC_MSG_ERROR(["Missing necessary header"])]
)
# Checks for DECLs.
@@ -68,92 +68,92 @@ AC_CHECK_FUNCS([memset strerror])
# Note: this is always needed for fix-gnustack
# and for paxctl-ng only with --enable-ptpax
AC_CHECK_LIB(
- [elf],
- [elf_begin],
- [],
- [AC_MSG_ERROR(["Missing necessary function elf_begin in libelf"])]
+ [elf],
+ [elf_begin],
+ [],
+ [AC_MSG_ERROR(["Missing necessary function elf_begin in libelf"])]
)
AC_ARG_ENABLE(
- [ptpax],
- AS_HELP_STRING(
- [--enable-ptpax],
- [enable support for pax markings in PT_PAX ELF phdr]
- )
+ [ptpax],
+ AS_HELP_STRING(
+ [--enable-ptpax],
+ [enable support for pax markings in PT_PAX ELF phdr]
+ )
)
AS_IF(
- [test "x$enable_ptpax" != "xno"],
- [
- AS_IF(
- [test "x$ac_cv_have_decl_ELF_C_RDWR_MMAP" = "xyes"],
- [
- AC_CHECK_DECLS(
- [PT_PAX_FLAGS, PF_PAGEEXEC, PF_MPROTECT, PF_RANDMMAP],
- [],
- [
- CFLAGS+=" -DNEED_PAX_DECLS"
- ],
- [[#include <gelf.h>]]
- )
- CFLAGS+=" -DPTPAX"
- ],
- [AC_MSG_ERROR(["Missing necessary DECL ELF_C_RDWR_MMAP in libelf"])]
- )
- ],
- [
- CFLAGS+=" -UPTPAX -DNEED_PAX_DECLS"
- ]
+ [test "x$enable_ptpax" != "xno"],
+ [
+ AS_IF(
+ [test "x$ac_cv_have_decl_ELF_C_RDWR_MMAP" = "xyes"],
+ [
+ AC_CHECK_DECLS(
+ [PT_PAX_FLAGS, PF_PAGEEXEC, PF_MPROTECT, PF_RANDMMAP],
+ [],
+ [
+ CFLAGS+=" -DNEED_PAX_DECLS"
+ ],
+ [[#include <gelf.h>]]
+ )
+ CFLAGS+=" -DPTPAX"
+ ],
+ [AC_MSG_ERROR(["Missing necessary DECL ELF_C_RDWR_MMAP in libelf"])]
+ )
+ ],
+ [
+ CFLAGS+=" -UPTPAX -DNEED_PAX_DECLS"
+ ]
)
AM_CONDITIONAL([BUILD_ELF],[test "x$enable_ptpax" = "xyes" && test "x$ac_cv_have_decl_ELF_C_RDWR_MMAP" = "xyes"])
AC_ARG_ENABLE(
- [xtpax],
- AS_HELP_STRING(
- [--enable-xtpax],
- [enable support for pax markings in xattrs]
- )
+ [xtpax],
+ AS_HELP_STRING(
+ [--enable-xtpax],
+ [enable support for pax markings in xattrs]
+ )
)
AS_IF(
- [test "x$enable_xtpax" != "xno"],
- [
- AC_CHECK_HEADERS(
- [attr/xattr.h],
- [],
- [AC_MSG_ERROR(["Missing necessary attr/xattr.h"])]
- )
- AC_CHECK_LIB(
- [attr],
- [fgetxattr],
- [],
- [AC_MSG_ERROR(["Missing necessary function fgetxattr in libattr"])]
- )
- CFLAGS+=" -DXTPAX"
- ],
- [
- CFLAGS+=" -UXTPAX"
- ]
+ [test "x$enable_xtpax" != "xno"],
+ [
+ AC_CHECK_HEADERS(
+ [attr/xattr.h],
+ [],
+ [AC_MSG_ERROR(["Missing necessary attr/xattr.h"])]
+ )
+ AC_CHECK_LIB(
+ [attr],
+ [fgetxattr],
+ [],
+ [AC_MSG_ERROR(["Missing necessary function fgetxattr in libattr"])]
+ )
+ CFLAGS+=" -DXTPAX"
+ ],
+ [
+ CFLAGS+=" -UXTPAX"
+ ]
)
if [test "x$enable_ptpax" = "xno" -a "x$enable_xtpax" = "xno" ]; then
- AC_MSG_ERROR(["You must enable either ptpax or xtpax"])
+ AC_MSG_ERROR(["You must enable either ptpax or xtpax"])
fi
AM_CONDITIONAL([DUALTEST],[test "x$enable_ptpax" = "xyes" -a "x$enable_xtpax" = "xyes"])
# Ready to configure our files
AC_CONFIG_FILES([
- Makefile
- src/Makefile
- scripts/Makefile
- doc/Makefile
- tests/Makefile
- tests/gnustack/Makefile
- tests/pxtpax/Makefile
- tests/paxmodule/Makefile
- tests/revdeppaxtest/Makefile
+ Makefile
+ src/Makefile
+ scripts/Makefile
+ doc/Makefile
+ tests/Makefile
+ tests/gnustack/Makefile
+ tests/pxtpax/Makefile
+ tests/paxmodule/Makefile
+ tests/revdeppaxtest/Makefile
])
AC_OUTPUT