summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-12-20 20:21:48 +0100
committerUlrich Müller <ulm@gentoo.org>2015-12-20 20:21:48 +0100
commita522741e3d974f314fa96b3672739a2dbf0ca43c (patch)
tree67570a505002ba0a2e6702e6f4b9b8c413565a6e
parentInclude changes for GCC 5 in Emacs 18.59 patchset. (diff)
downloademacs-patches-a522741e3d974f314fa96b3672739a2dbf0ca43c.tar.gz
emacs-patches-a522741e3d974f314fa96b3672739a2dbf0ca43c.tar.bz2
emacs-patches-a522741e3d974f314fa96b3672739a2dbf0ca43c.zip
Fix jpeg version check in Emacs 23.4 to work with GCC 5.emacs-23.4-patches-18
-rw-r--r--emacs/23.4/25_all_jpeg-version.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/emacs/23.4/25_all_jpeg-version.patch b/emacs/23.4/25_all_jpeg-version.patch
new file mode 100644
index 0000000..8b82827
--- /dev/null
+++ b/emacs/23.4/25_all_jpeg-version.patch
@@ -0,0 +1,25 @@
+Fix jpeg version check to work with gcc >= 5.
+Comprises part of the following commit from the emacs-24 branch:
+
+commit ff3878d749591ebf78da532ec1eb6fa00cb5757d
+Author: Andreas Schwab <schwab@suse.de>
+Date: Mon Mar 23 11:55:24 2015 +0100
+
+ * configure.ac: Fix jpeg version check to work with gcc >= 5.
+
+--- emacs-23.4-orig/configure.in
++++ emacs-23.4/configure.in
+@@ -2176,9 +2176,11 @@
+ AH_TEMPLATE(HAVE_JPEG, [Define to 1 if you have the jpeg library (-ljpeg).])dnl
+ if test "${HAVE_JPEG}" = "yes"; then
+ AC_DEFINE(HAVE_JPEG)
+- AC_EGREP_CPP([version= *(6[2-9]|[7-9][0-9])],
++ AC_EGREP_CPP([version 6b or later],
+ [#include <jpeglib.h>
+- version=JPEG_LIB_VERSION
++ #if JPEG_LIB_VERSION >= 62
++ version 6b or later
++ #endif
+ ],
+ [AC_DEFINE(HAVE_JPEG)],
+ [AC_MSG_WARN([libjpeg found, but not version 6b or later])