summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-06-04 16:58:10 +0200
committerUlrich Müller <ulm@gentoo.org>2023-06-04 16:58:10 +0200
commit79ce48ab7ebc20f72ab3bc6c423e7ddb586fd430 (patch)
tree729e60ec4c9ea09cb427be4ad8a8c00bafb02113
parent28.3: Number patches consecutively (diff)
downloademacs-patches-79ce48ab7ebc20f72ab3bc6c423e7ddb586fd430.tar.gz
emacs-patches-79ce48ab7ebc20f72ab3bc6c423e7ddb586fd430.tar.bz2
emacs-patches-79ce48ab7ebc20f72ab3bc6c423e7ddb586fd430.zip
28.3: Update patchsetemacs-28.3-patches-1
Disable failing copyright tests. Cherry-pick tramp version patch from emacs-28 branch. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--emacs/28.3/03_all_copyright-test.patch20
-rw-r--r--emacs/28.3/04_all_tramp-version.patch58
2 files changed, 78 insertions, 0 deletions
diff --git a/emacs/28.3/03_all_copyright-test.patch b/emacs/28.3/03_all_copyright-test.patch
new file mode 100644
index 0000000..32a64c3
--- /dev/null
+++ b/emacs/28.3/03_all_copyright-test.patch
@@ -0,0 +1,20 @@
+Disable failing copyright tests
+
+--- a/test/lisp/emacs-lisp/copyright-tests.el
++++ b/test/lisp/emacs-lisp/copyright-tests.el
+@@ -51,6 +51,7 @@
+ (with-copyright-test (car test) (cdr test))))
+
+ (ert-deftest test-end-chop ()
++ :tags '(:unstable)
+ (should
+ (equal
+ (with-temp-buffer
+@@ -62,6 +63,7 @@
+ "Copyright 2006, 2007, 2008, 2022 Foo Bar\n\n")))
+
+ (ert-deftest test-correct-notice ()
++ :tags '(:unstable)
+ (should (equal
+ (with-temp-buffer
+ (dotimes (_ 2)
diff --git a/emacs/28.3/04_all_tramp-version.patch b/emacs/28.3/04_all_tramp-version.patch
new file mode 100644
index 0000000..757f7ac
--- /dev/null
+++ b/emacs/28.3/04_all_tramp-version.patch
@@ -0,0 +1,58 @@
+Adapt Tramp versions
+Patch from emacs-28 branch
+
+commit dec958258b133b4c21224c594da433919d852800
+Author: Michael Albinus <michael.albinus@gmx.de>
+Date: Fri Feb 24 19:42:27 2023 +0100
+
+ Adapt Tramp versions. Do not merge
+
+--- a/doc/misc/trampver.texi
++++ b/doc/misc/trampver.texi
+@@ -8,7 +8,7 @@
+ @c In the Tramp GIT, the version numbers are auto-frobbed from
+ @c tramp.el, and the bug report address is auto-frobbed from
+ @c configure.ac.
+-@set trampver 2.5.4-pre
++@set trampver 2.5.4
+ @set trampurl https://www.gnu.org/software/tramp/
+ @set tramp-bug-report-address tramp-devel@@gnu.org
+ @set emacsver 25.1
+--- a/lisp/net/trampver.el
++++ b/lisp/net/trampver.el
+@@ -7,7 +7,7 @@
+ ;; Maintainer: Michael Albinus <michael.albinus@gmx.de>
+ ;; Keywords: comm, processes
+ ;; Package: tramp
+-;; Version: 2.5.4-pre
++;; Version: 2.5.4
+ ;; Package-Requires: ((emacs "25.1"))
+ ;; Package-Type: multi
+ ;; URL: https://www.gnu.org/software/tramp/
+@@ -40,7 +40,7 @@
+ ;; ./configure" to change them.
+
+ ;;;###tramp-autoload
+-(defconst tramp-version "2.5.4-pre"
++(defconst tramp-version "2.5.4"
+ "This version of Tramp.")
+
+ ;;;###tramp-autoload
+@@ -78,7 +78,7 @@
+ ;; Check for Emacs version.
+ (let ((x (if (not (string-lessp emacs-version "25.1"))
+ "ok"
+- (format "Tramp 2.5.4-pre is not fit for %s"
++ (format "Tramp 2.5.4 is not fit for %s"
+ (replace-regexp-in-string "\n" "" (emacs-version))))))
+ (unless (string-equal "ok" x) (error "%s" x)))
+
+@@ -104,7 +104,7 @@
+ ("2.3.3" . "26.1") ("2.3.3.26.1" . "26.1") ("2.3.5.26.2" . "26.2")
+ ("2.3.5.26.3" . "26.3")
+ ("2.4.3.27.1" . "27.1") ("2.4.5.27.2" . "27.2")
+- ("2.5.2.28.1" . "28.1") ("2.5.3.28.2" . "28.2")))
++ ("2.5.2.28.1" . "28.1") ("2.5.3.28.2" . "28.2") ("2.5.4" . "28.3")))
+
+ (add-hook 'tramp-unload-hook
+ (lambda ()