summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-01-08 21:00:11 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-01-08 21:00:11 -0500
commit41f92b84f7871ae913bf8a462b88a3808f1df208 (patch)
treed523e290552a2b62ff6deed04dd7179dfbdfb0ba
parentBump to v0.8.3 in configure.ac. (diff)
downloadeselect-php-41f92b84f7871ae913bf8a462b88a3808f1df208.tar.gz
eselect-php-41f92b84f7871ae913bf8a462b88a3808f1df208.tar.bz2
eselect-php-41f92b84f7871ae913bf8a462b88a3808f1df208.zip
Fix the "show" action for SAPIs other than phpdbg.
-rw-r--r--src/php.eselect.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/php.eselect.in b/src/php.eselect.in
index b47d218..d9c44f7 100644
--- a/src/php.eselect.in
+++ b/src/php.eselect.in
@@ -564,8 +564,9 @@ describe_show_options() {
}
do_show() {
- check_module $1
- get_active_$1
+ local sapi="${1}"
+ check_module "${sapi}"
+ get_sapi_active_target "${sapi}"
}
## update action